summaryrefslogtreecommitdiffstats
path: root/odk/Executable_unoapploader.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /odk/Executable_unoapploader.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/Executable_unoapploader.mk')
-rw-r--r--odk/Executable_unoapploader.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/odk/Executable_unoapploader.mk b/odk/Executable_unoapploader.mk
new file mode 100644
index 000000000..3128a3ba4
--- /dev/null
+++ b/odk/Executable_unoapploader.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,unoapploader))
+
+$(eval $(call gb_Executable_use_static_libraries,unoapploader,\
+ findsofficepath \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Executable_set_targettype_gui,unoapploader,YES))
+
+$(eval $(call gb_Executable_add_cobjects,unoapploader,\
+ odk/source/unoapploader/win/unoapploader \
+))
+
+$(eval $(call gb_Executable_use_system_win32_libs,unoapploader,\
+ advapi32 \
+))
+else
+$(eval $(call gb_Executable_add_cobjects,unoapploader,\
+ odk/source/unoapploader/unx/unoapploader \
+))
+
+$(eval $(call gb_Executable_add_libs,unoapploader,\
+ $(if $(filter-out FREEBSD NETBSD DRAGONFLY,$(OS)),-ldl) \
+))
+endif
+
+# vim: set ts=4 sw=4 et: