summaryrefslogtreecommitdiffstats
path: root/onlineupdate/qa
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /onlineupdate/qa
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'onlineupdate/qa')
-rw-r--r--onlineupdate/qa/lang_packs/Makefile21
-rw-r--r--onlineupdate/qa/lang_packs/update_en_signed.marbin0 -> 667 bytes
-rw-r--r--onlineupdate/qa/lang_packs/update_signed.marbin0 -> 650 bytes
-rw-r--r--onlineupdate/qa/lang_packs/updater_lang.zipbin0 -> 899 bytes
-rw-r--r--onlineupdate/qa/replace_request/Makefile17
-rw-r--r--onlineupdate/qa/replace_request/README3
-rw-r--r--onlineupdate/qa/replace_request/updater.zipbin0 -> 1519 bytes
-rw-r--r--onlineupdate/qa/single_step/Makefile27
-rw-r--r--onlineupdate/qa/single_step/complete_signed.marbin0 -> 2025 bytes
-rw-r--r--onlineupdate/qa/single_step/incremental_signed.marbin0 -> 730 bytes
-rw-r--r--onlineupdate/qa/single_step/single_step.zipbin0 -> 1271 bytes
11 files changed, 68 insertions, 0 deletions
diff --git a/onlineupdate/qa/lang_packs/Makefile b/onlineupdate/qa/lang_packs/Makefile
new file mode 100644
index 000000000..d328472f5
--- /dev/null
+++ b/onlineupdate/qa/lang_packs/Makefile
@@ -0,0 +1,21 @@
+gb_Side := host
+include ../../../config_host.mk
+
+UPDATER_DIR := $(WORKDIR)/updater/lang_pack
+
+all : call
+
+unpack:
+ @echo "Unpacking the updater test project"
+ @rm -r $(UPDATER_DIR) || true
+ @mkdir -p $(WORKDIR)/updater/
+ @unzip updater_lang.zip -d $(WORKDIR)/updater > /dev/null
+ @cp update_signed.mar $(UPDATER_DIR)/user/patch/update.mar
+ @cp update_en_signed.mar $(UPDATER_DIR)/user/patch/update_en_signed.mar
+
+call: unpack
+ @echo "Update the test project"
+ @$(INSTDIR)/program/updater $(UPDATER_DIR)/user/patch $(UPDATER_DIR) $(UPDATER_DIR)/user/update -1
+
+call-gdb: unpack
+ gdb --args $(INSTDIR)/program/updater $(UPDATER_DIR)/user/patch $(UPDATER_DIR) $(UPDATER_DIR)/user/update -1
diff --git a/onlineupdate/qa/lang_packs/update_en_signed.mar b/onlineupdate/qa/lang_packs/update_en_signed.mar
new file mode 100644
index 000000000..b72d1c5df
--- /dev/null
+++ b/onlineupdate/qa/lang_packs/update_en_signed.mar
Binary files differ
diff --git a/onlineupdate/qa/lang_packs/update_signed.mar b/onlineupdate/qa/lang_packs/update_signed.mar
new file mode 100644
index 000000000..a145d6325
--- /dev/null
+++ b/onlineupdate/qa/lang_packs/update_signed.mar
Binary files differ
diff --git a/onlineupdate/qa/lang_packs/updater_lang.zip b/onlineupdate/qa/lang_packs/updater_lang.zip
new file mode 100644
index 000000000..05b206bc8
--- /dev/null
+++ b/onlineupdate/qa/lang_packs/updater_lang.zip
Binary files differ
diff --git a/onlineupdate/qa/replace_request/Makefile b/onlineupdate/qa/replace_request/Makefile
new file mode 100644
index 000000000..476e93213
--- /dev/null
+++ b/onlineupdate/qa/replace_request/Makefile
@@ -0,0 +1,17 @@
+gb_Side := host
+include ../../../config_host.mk
+
+UPDATER_DIR := $(WORKDIR)/updater/replace_request
+
+unpack:
+ @echo "Unpacking the updater test project"
+ @rm -r $(UPDATER_DIR) || true
+ @mkdir -p $(WORKDIR)/updater
+ @unzip updater.zip -d $(WORKDIR)/updater > /dev/null
+
+call: unpack
+ @echo "Update the test project"
+ @$(INSTDIR)/program/updater $(UPDATER_DIR)/user/patch $(UPDATER_DIR) $(UPDATER_DIR)/user/update /replace
+
+call-gdb: unpack
+ gdb --args $(INSTDIR)/program/updater $(UPDATER_DIR)/user/patch $(UPDATER_DIR) $(UPDATER_DIR)/user/update /replace
diff --git a/onlineupdate/qa/replace_request/README b/onlineupdate/qa/replace_request/README
new file mode 100644
index 000000000..f50c692fd
--- /dev/null
+++ b/onlineupdate/qa/replace_request/README
@@ -0,0 +1,3 @@
+Tests the replacement request done by the automatic updater
+
+After calling 'make call' the content in workdir/updater/program/datei.txt should say "new".
diff --git a/onlineupdate/qa/replace_request/updater.zip b/onlineupdate/qa/replace_request/updater.zip
new file mode 100644
index 000000000..dc5e26b0f
--- /dev/null
+++ b/onlineupdate/qa/replace_request/updater.zip
Binary files differ
diff --git a/onlineupdate/qa/single_step/Makefile b/onlineupdate/qa/single_step/Makefile
new file mode 100644
index 000000000..f303992ba
--- /dev/null
+++ b/onlineupdate/qa/single_step/Makefile
@@ -0,0 +1,27 @@
+gb_Side := host
+include ../../../config_host.mk
+
+UPDATER_DIR := $(WORKDIR)/updater/single_step
+
+all : call
+
+unpack:
+ @echo "Unpacking the updater test project"
+ @rm -r $(UPDATER_DIR) || true
+ @mkdir -p $(UPDATER_DIR)
+ @unzip single_step.zip -d $(WORKDIR)/updater > /dev/null
+ @mkdir -p $(UPDATER_DIR)/patch
+
+call-complete: unpack
+ @echo "Update the test project"
+ @cp complete_signed.mar $(UPDATER_DIR)/patch/update.mar
+ @$(INSTDIR)/program/updater $(UPDATER_DIR)/patch $(UPDATER_DIR) $(UPDATER_DIR) 0
+
+call-incremental: unpack
+ @echo "Update the test project"
+ @cp incremental_signed.mar $(UPDATER_DIR)/patch/update.mar
+ @$(INSTDIR)/program/updater $(UPDATER_DIR)/patch $(UPDATER_DIR) $(UPDATER_DIR) 0
+
+call-gdb: unpack
+ @cp incremental_signed.mar $(UPDATER_DIR)/patch/update.mar
+ gdb --args $(INSTDIR)/program/updater $(UPDATER_DIR)/patch $(UPDATER_DIR) $(UPDATER_DIR) 0
diff --git a/onlineupdate/qa/single_step/complete_signed.mar b/onlineupdate/qa/single_step/complete_signed.mar
new file mode 100644
index 000000000..7b0631dd3
--- /dev/null
+++ b/onlineupdate/qa/single_step/complete_signed.mar
Binary files differ
diff --git a/onlineupdate/qa/single_step/incremental_signed.mar b/onlineupdate/qa/single_step/incremental_signed.mar
new file mode 100644
index 000000000..6ec6e7a1a
--- /dev/null
+++ b/onlineupdate/qa/single_step/incremental_signed.mar
Binary files differ
diff --git a/onlineupdate/qa/single_step/single_step.zip b/onlineupdate/qa/single_step/single_step.zip
new file mode 100644
index 000000000..823a590e0
--- /dev/null
+++ b/onlineupdate/qa/single_step/single_step.zip
Binary files differ