summaryrefslogtreecommitdiffstats
path: root/oox/Module_oox.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /oox/Module_oox.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'oox/Module_oox.mk')
-rw-r--r--oox/Module_oox.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/oox/Module_oox.mk b/oox/Module_oox.mk
new file mode 100644
index 000000000..75ef85051
--- /dev/null
+++ b/oox/Module_oox.mk
@@ -0,0 +1,35 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,oox))
+
+$(eval $(call gb_Module_add_targets,oox,\
+ CustomTarget_generated \
+ Library_oox \
+ Package_customshapes \
+ Package_generated \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,oox,\
+ AllLangMoTarget_oox \
+))
+
+$(eval $(call gb_Module_add_check_targets,oox,\
+ CppunitTest_oox_tokenmap \
+ CppunitTest_oox_vba_compression \
+ CppunitTest_oox_vba_encryption \
+ CppunitTest_oox_crypto \
+ CppunitTest_oox_mathml \
+ CppunitTest_oox_drawingml \
+ CppunitTest_oox_vml \
+ CppunitTest_oox_shape \
+ CppunitTest_oox_export \
+))
+
+# vim: set noet sw=4 ts=4: