summaryrefslogtreecommitdiffstats
path: root/qadevOOo/testdocs/qadevlibs/source/test
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /qadevOOo/testdocs/qadevlibs/source/test
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'qadevOOo/testdocs/qadevlibs/source/test')
-rw-r--r--qadevOOo/testdocs/qadevlibs/source/test/Job.java104
-rw-r--r--qadevOOo/testdocs/qadevlibs/source/test/makefile.mk55
-rw-r--r--qadevOOo/testdocs/qadevlibs/source/test/manifest2
3 files changed, 161 insertions, 0 deletions
diff --git a/qadevOOo/testdocs/qadevlibs/source/test/Job.java b/qadevOOo/testdocs/qadevlibs/source/test/Job.java
new file mode 100644
index 000000000..40d0c09c3
--- /dev/null
+++ b/qadevOOo/testdocs/qadevlibs/source/test/Job.java
@@ -0,0 +1,104 @@
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+package test;
+
+import com.sun.star.task.XJob;
+import com.sun.star.lang.XSingleServiceFactory;
+import com.sun.star.beans.*;
+import com.sun.star.container.*;
+import com.sun.star.lang.XServiceInfo;
+import com.sun.star.lang.XTypeProvider;
+import com.sun.star.uno.Type;
+import com.sun.star.lang.XMultiServiceFactory;
+import com.sun.star.registry.XRegistryKey;
+import com.sun.star.comp.loader.FactoryHelper;
+
+public class Job {
+
+ public static class _Implementation implements XServiceInfo, XTypeProvider,
+ XJob, XNamed {
+ private static final String __serviceName = "test.Job";
+ Object oDoc = null;
+ String actionType = null;
+ String actionParm = null;
+
+ public _Implementation(XMultiServiceFactory xMSF) {
+ }
+
+ // XServiceInfo
+ public String getImplementationName()
+ throws com.sun.star.uno.RuntimeException {
+ return getClass().getName();
+ }
+
+ public boolean supportsService(String serviceName)
+ throws com.sun.star.uno.RuntimeException {
+ return __serviceName.equals(serviceName);
+ }
+
+ public String[] getSupportedServiceNames()
+ throws com.sun.star.uno.RuntimeException {
+ return new String[] { __serviceName };
+ }
+
+ private static int executed = 0;
+
+ public Object execute(NamedValue[] args) {
+ executed++;
+
+ return null;
+ }
+
+ public String getName() {
+ return "" + executed;
+ }
+
+ public void setName(String n) {
+ }
+
+ public byte[] getImplementationId() {
+ return new byte[0];
+ }
+
+ public Type[] getTypes() {
+ Class<?> interfaces[] = getClass().getInterfaces();
+ Type types[] = new Type[interfaces.length];
+ for (int i = 0; i < interfaces.length; ++i)
+ types[i] = new Type(interfaces[i]);
+ return types;
+ }
+
+ }
+
+ public static XSingleServiceFactory __getServiceFactory(
+ XMultiServiceFactory multiFactory, XRegistryKey regKey) {
+ XSingleServiceFactory xSingleServiceFactory = null;
+ xSingleServiceFactory = FactoryHelper.getServiceFactory(
+ _Implementation.class, _Implementation.__serviceName,
+ multiFactory, regKey);
+ return xSingleServiceFactory;
+ }
+
+ public static boolean __writeRegistryServiceInfo(XRegistryKey regKey) {
+ boolean result = true;
+ result = FactoryHelper.writeRegistryServiceInfo(
+ _Implementation.class.getName(), _Implementation.__serviceName,
+ regKey);
+ return result;
+ }
+}
diff --git a/qadevOOo/testdocs/qadevlibs/source/test/makefile.mk b/qadevOOo/testdocs/qadevlibs/source/test/makefile.mk
new file mode 100644
index 000000000..27115c251
--- /dev/null
+++ b/qadevOOo/testdocs/qadevlibs/source/test/makefile.mk
@@ -0,0 +1,55 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ = ..$/..$/..$/..
+PRJNAME = JobExecutor
+TARGET = $(PRJNAME)
+PACKAGE = test
+
+# --- Settings -----------------------------------------------------
+.INCLUDE: settings.mk
+
+#----- compile .java files -----------------------------------------
+
+JARFILES = ridl.jar unoil.jar jurt.jar juh.jar java_uno.jar OOoRunner.jar
+JAVAFILES = Job.java
+JAVACLASSFILES = $(CLASSDIR)$/$(PACKAGE)$/Job.class
+
+#----- make a jar from compiled files ------------------------------
+
+MAXLINELENGTH = 100000
+
+JARCLASSDIRS = test
+JARTARGET = $(TARGET).jar
+JARCOMPRESS = TRUE
+CUSTOMMANIFESTFILE = manifest
+
+
+# --- Files --------------------------------------------------------
+
+# --- Targets ------------------------------------------------------
+
+.IF "$(depend)" == ""
+ALL : \
+ ALLTAR
+.ELSE
+ALL: ALLDEP
+.ENDIF
+
+.INCLUDE : target.mk
+
diff --git a/qadevOOo/testdocs/qadevlibs/source/test/manifest b/qadevOOo/testdocs/qadevlibs/source/test/manifest
new file mode 100644
index 000000000..02f702337
--- /dev/null
+++ b/qadevOOo/testdocs/qadevlibs/source/test/manifest
@@ -0,0 +1,2 @@
+RegistrationClassName: test.Job
+ \ No newline at end of file