summaryrefslogtreecommitdiffstats
path: root/remotebridges
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /remotebridges
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remotebridges')
-rw-r--r--remotebridges/Library_uuresolver.mk26
-rw-r--r--remotebridges/Makefile7
-rw-r--r--remotebridges/Module_remotebridges.mk16
-rw-r--r--remotebridges/README.md3
-rw-r--r--remotebridges/source/unourl_resolver/unourl_resolver.cxx129
-rw-r--r--remotebridges/source/unourl_resolver/uuresolver.component26
6 files changed, 207 insertions, 0 deletions
diff --git a/remotebridges/Library_uuresolver.mk b/remotebridges/Library_uuresolver.mk
new file mode 100644
index 000000000..bb41a3f1b
--- /dev/null
+++ b/remotebridges/Library_uuresolver.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,uuresolver))
+
+$(eval $(call gb_Library_set_componentfile,uuresolver,remotebridges/source/unourl_resolver/uuresolver,ure/services))
+
+$(eval $(call gb_Library_use_udk_api,uuresolver))
+
+$(eval $(call gb_Library_use_libraries,uuresolver,\
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_add_exception_objects,uuresolver,\
+ remotebridges/source/unourl_resolver/unourl_resolver \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab:
diff --git a/remotebridges/Makefile b/remotebridges/Makefile
new file mode 100644
index 000000000..ccb1c85a0
--- /dev/null
+++ b/remotebridges/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/remotebridges/Module_remotebridges.mk b/remotebridges/Module_remotebridges.mk
new file mode 100644
index 000000000..c177db0e7
--- /dev/null
+++ b/remotebridges/Module_remotebridges.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,remotebridges))
+
+$(eval $(call gb_Module_add_targets,remotebridges,\
+ Library_uuresolver \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab:
diff --git a/remotebridges/README.md b/remotebridges/README.md
new file mode 100644
index 000000000..8f1879f86
--- /dev/null
+++ b/remotebridges/README.md
@@ -0,0 +1,3 @@
+# Bridges to UNO Services
+
+UNO services dealing with interprocess bridges.
diff --git a/remotebridges/source/unourl_resolver/unourl_resolver.cxx b/remotebridges/source/unourl_resolver/unourl_resolver.cxx
new file mode 100644
index 000000000..6dc273ab3
--- /dev/null
+++ b/remotebridges/source/unourl_resolver/unourl_resolver.cxx
@@ -0,0 +1,129 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+#include <rtl/malformeduriexception.hxx>
+
+#include <com/sun/star/lang/XComponent.hpp>
+#include <com/sun/star/lang/XServiceInfo.hpp>
+#include <com/sun/star/bridge/BridgeFactory.hpp>
+#include <com/sun/star/bridge/XBridgeFactory.hpp>
+#include <com/sun/star/bridge/XUnoUrlResolver.hpp>
+#include <com/sun/star/connection/XConnector.hpp>
+#include <cppuhelper/implbase.hxx>
+#include <cppuhelper/supportsservice.hxx>
+#include <cppuhelper/unourl.hxx>
+
+using namespace cppu;
+using namespace com::sun::star::uno;
+using namespace com::sun::star::lang;
+using namespace com::sun::star::connection;
+using namespace com::sun::star::bridge;
+
+namespace unourl_resolver
+{
+
+namespace {
+
+class ResolverImpl : public WeakImplHelper< XServiceInfo, XUnoUrlResolver >
+{
+ Reference< XMultiComponentFactory > _xSMgr;
+ Reference< XComponentContext > _xCtx;
+
+public:
+ explicit ResolverImpl( const Reference< XComponentContext > & xSMgr );
+
+ // XServiceInfo
+ virtual OUString SAL_CALL getImplementationName() override;
+ virtual sal_Bool SAL_CALL supportsService( const OUString & rServiceName ) override;
+ virtual Sequence< OUString > SAL_CALL getSupportedServiceNames() override;
+
+ // XUnoUrlResolver
+ virtual Reference< XInterface > SAL_CALL resolve( const OUString & rUnoUrl ) override;
+};
+
+}
+
+ResolverImpl::ResolverImpl( const Reference< XComponentContext > & xCtx )
+ : _xSMgr( xCtx->getServiceManager() )
+ , _xCtx( xCtx )
+{}
+
+// XServiceInfo
+OUString ResolverImpl::getImplementationName()
+{
+ return "com.sun.star.comp.bridge.UnoUrlResolver";
+}
+
+sal_Bool ResolverImpl::supportsService( const OUString & rServiceName )
+{
+ return cppu::supportsService(this, rServiceName);
+}
+
+Sequence< OUString > ResolverImpl::getSupportedServiceNames()
+{
+ return { "com.sun.star.bridge.UnoUrlResolver" };
+}
+
+// XUnoUrlResolver
+Reference< XInterface > ResolverImpl::resolve( const OUString & rUnoUrl )
+{
+ OUString aProtocolDescr;
+ OUString aConnectDescr;
+ OUString aInstanceName;
+ try
+ {
+ cppu::UnoUrl aUrl(rUnoUrl);
+ aProtocolDescr = aUrl.getProtocol().getDescriptor();
+ aConnectDescr = aUrl.getConnection().getDescriptor();
+ aInstanceName = aUrl.getObjectName();
+ }
+ catch (const rtl::MalformedUriException & rEx)
+ {
+ throw ConnectionSetupException(rEx.getMessage(), nullptr);
+ }
+
+ Reference< XConnector > xConnector(
+ _xSMgr->createInstanceWithContext( "com.sun.star.connection.Connector", _xCtx ),
+ UNO_QUERY_THROW );
+ Reference< XConnection > xConnection( xConnector->connect( aConnectDescr ) );
+
+ // As soon as singletons are ready, switch to singleton !
+ Reference< XBridgeFactory2 > xBridgeFactory( BridgeFactory::create(_xCtx) );
+
+ // bridge
+ Reference< XBridge > xBridge( xBridgeFactory->createBridge(
+ OUString(), aProtocolDescr,
+ xConnection, Reference< XInstanceProvider >() ) );
+
+ Reference< XInterface > xRet( xBridge->getInstance( aInstanceName ) );
+
+ return xRet;
+}
+
+
+extern "C" SAL_DLLPUBLIC_EXPORT css::uno::XInterface*
+remotebridges_ResolverImpl_get_implementation(
+ css::uno::XComponentContext* context, css::uno::Sequence<css::uno::Any> const&)
+{
+ return cppu::acquire(new ResolverImpl(context));
+}
+
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/remotebridges/source/unourl_resolver/uuresolver.component b/remotebridges/source/unourl_resolver/uuresolver.component
new file mode 100644
index 000000000..4b830459a
--- /dev/null
+++ b/remotebridges/source/unourl_resolver/uuresolver.component
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ -->
+
+<component loader="com.sun.star.loader.SharedLibrary" environment="@CPPU_ENV@"
+ xmlns="http://openoffice.org/2010/uno-components">
+ <implementation name="com.sun.star.comp.bridge.UnoUrlResolver"
+ constructor="remotebridges_ResolverImpl_get_implementation">
+ <service name="com.sun.star.bridge.UnoUrlResolver"/>
+ </implementation>
+</component>