summaryrefslogtreecommitdiffstats
path: root/ridljar/Jar_unoloader.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /ridljar/Jar_unoloader.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ridljar/Jar_unoloader.mk')
-rw-r--r--ridljar/Jar_unoloader.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/ridljar/Jar_unoloader.mk b/ridljar/Jar_unoloader.mk
new file mode 100644
index 000000000..2acf20b5b
--- /dev/null
+++ b/ridljar/Jar_unoloader.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,unoloader,org.libreoffice.unoloader))
+
+$(eval $(call gb_Jar_set_packageroot,unoloader,com))
+
+$(eval $(call gb_Jar_set_manifest,unoloader,$(SRCDIR)/ridljar/source/unoloader/com/sun/star/lib/unoloader/manifest))
+
+# the module-info.class is manually added here since it's not in "com" dir
+$(eval $(call gb_Jar_add_packagedirs,unoloader,\
+ $(call gb_JavaClassSet_get_classdir,$(call gb_Jar_get_classsetname,unoloader))/module-info.class \
+))
+
+$(eval $(call gb_Jar_add_sourcefiles_java9,unoloader,\
+ ridljar/source/unoloader/module-info \
+))
+
+$(eval $(call gb_Jar_add_sourcefiles,unoloader,\
+ ridljar/source/unoloader/com/sun/star/lib/unoloader/UnoClassLoader \
+ ridljar/source/unoloader/com/sun/star/lib/unoloader/UnoLoader \
+))
+
+# vim:set noet sw=4 ts=4: