summaryrefslogtreecommitdiffstats
path: root/sc/JunitTest_sc_complex.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sc/JunitTest_sc_complex.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sc/JunitTest_sc_complex.mk')
-rw-r--r--sc/JunitTest_sc_complex.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/sc/JunitTest_sc_complex.mk b/sc/JunitTest_sc_complex.mk
new file mode 100644
index 000000000..cfd869b91
--- /dev/null
+++ b/sc/JunitTest_sc_complex.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_JunitTest_JunitTest,sc_complex))
+
+# sc/qa/complex/calcPreview/ tests do not work automatically (they request "Press
+# any key after resizing" etc.)
+
+$(eval $(call gb_JunitTest_add_classes,sc_complex, \
+ complex.sc.CalcRTL \
+))
+
+$(eval $(call gb_JunitTest_use_unoapi_jars,sc_complex))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,sc_complex, \
+ sc/qa/complex/dataPilot/_XDataPilotDescriptor \
+ sc/qa/complex/dataPilot/_XDataPilotTable \
+ sc/qa/complex/dataPilot/_XNamed \
+ sc/qa/complex/dataPilot/_XPropertySet \
+ sc/qa/complex/sc/CalcRTL \
+))
+
+$(eval $(call gb_JunitTest_set_defs,sc_complex, \
+ $$(DEFS) \
+))
+
+# vim: set noet sw=4 ts=4: