summaryrefslogtreecommitdiffstats
path: root/scaddins/Library_date.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scaddins/Library_date.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scaddins/Library_date.mk')
-rw-r--r--scaddins/Library_date.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/scaddins/Library_date.mk b/scaddins/Library_date.mk
new file mode 100644
index 000000000..b39cfeeb8
--- /dev/null
+++ b/scaddins/Library_date.mk
@@ -0,0 +1,51 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,date))
+
+$(eval $(call gb_Library_set_componentfile,date,scaddins/source/datefunc/date,services))
+
+$(eval $(call gb_Library_set_include,date,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/scaddins/inc \
+))
+
+$(eval $(call gb_Library_use_external,date,boost_headers))
+
+$(eval $(call gb_Library_use_common_precompiled_header,date))
+
+$(eval $(call gb_Library_use_internal_comprehensive_api,date,\
+ offapi \
+ scaddins \
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_libraries,date,\
+ cppu \
+ cppuhelper \
+ sal \
+ utl \
+ i18nlangtag \
+))
+
+$(eval $(call gb_Library_add_exception_objects,date,\
+ scaddins/source/datefunc/datefunc \
+))
+
+# vim: set noet sw=4 ts=4: