summaryrefslogtreecommitdiffstats
path: root/sccomp/CppunitTest_sccomp_solver.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sccomp/CppunitTest_sccomp_solver.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sccomp/CppunitTest_sccomp_solver.mk')
-rw-r--r--sccomp/CppunitTest_sccomp_solver.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/sccomp/CppunitTest_sccomp_solver.mk b/sccomp/CppunitTest_sccomp_solver.mk
new file mode 100644
index 000000000..d634fb7d9
--- /dev/null
+++ b/sccomp/CppunitTest_sccomp_solver.mk
@@ -0,0 +1,47 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,sccomp_solver))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sccomp_solver,\
+ sccomp/qa/unit/solver \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sccomp_solver,\
+ boost_headers \
+))
+
+$(eval $(call gb_CppunitTest_add_defs,sccomp_solver,\
+ $(if $(ENABLE_COINMP), -DENABLE_COINMP) \
+ $(if $(ENABLE_LPSOLVE), -DENABLE_LPSOLVE) \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sccomp_solver,\
+ cppu \
+ sal \
+ test \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sccomp_solver,\
+ -I$(SRCDIR)/sc/inc \
+ $$(INCLUDE) \
+))
+
+
+$(eval $(call gb_CppunitTest_use_sdk_api,sccomp_solver))
+
+$(eval $(call gb_CppunitTest_use_ure,sccomp_solver))
+$(eval $(call gb_CppunitTest_use_vcl,sccomp_solver))
+
+$(eval $(call gb_CppunitTest_use_rdb,sccomp_solver,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,sccomp_solver))
+
+# vim: set noet sw=4 ts=4: