summaryrefslogtreecommitdiffstats
path: root/scp2/InstallModule_ooo.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scp2/InstallModule_ooo.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scp2/InstallModule_ooo.mk')
-rw-r--r--scp2/InstallModule_ooo.mk96
1 files changed, 96 insertions, 0 deletions
diff --git a/scp2/InstallModule_ooo.mk b/scp2/InstallModule_ooo.mk
new file mode 100644
index 000000000..8739b86cf
--- /dev/null
+++ b/scp2/InstallModule_ooo.mk
@@ -0,0 +1,96 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InstallModule_InstallModule,scp2/ooo))
+
+$(eval $(call gb_InstallModule_use_auto_install_libs,scp2/ooo,\
+ brand \
+ libreofficekit \
+ ooo \
+ ooo_fonts \
+ ooo_images \
+ ooobinarytable \
+ pdfimport \
+ reportbuilder \
+))
+
+$(eval $(call gb_InstallModule_define_if_set,scp2/ooo,\
+ ENABLE_MACOSX_SANDBOX \
+ ENABLE_ONLINE_UPDATE \
+ SYSTEM_CURL \
+ SYSTEM_HSQLDB \
+ SYSTEM_LIBXSLT \
+ SYSTEM_REDLAND \
+ WITH_GALLERY_BUILD \
+ WITH_MYSPELL_DICTS \
+))
+
+$(eval $(call gb_InstallModule_add_defs,scp2/ooo,\
+ $(if $(SYSTEM_HSQLDB),\
+ -DHSQLDB_JAR=\""$(call gb_Helper_make_url,$(HSQLDB_JAR))"\" \
+ ) \
+))
+
+ifeq ($(USING_X11),TRUE)
+$(eval $(call gb_InstallModule_add_defs,scp2/ooo,\
+ -DUSING_X11 \
+))
+endif
+
+ifneq (,$(filter DBCONNECTIVITY,$(BUILD_TYPE)))
+$(eval $(call gb_InstallModule_add_defs,scp2/ooo,\
+ -DDBCONNECTIVITY \
+))
+endif
+
+$(eval $(call gb_InstallModule_add_templates,scp2/ooo,\
+ scp2/source/templates/module_helppack \
+ scp2/source/templates/module_helppack_root \
+ scp2/source/templates/module_langpack \
+ scp2/source/templates/module_langpack_root \
+))
+
+$(eval $(call gb_InstallModule_add_scpfiles,scp2/ooo,\
+ scp2/source/ooo/common_brand \
+ scp2/source/ooo/directory_ooo \
+ scp2/source/ooo/directory_ooo_macosx \
+ scp2/source/ooo/file_extra_ooo \
+ scp2/source/ooo/file_library_ooo \
+ scp2/source/ooo/file_ooo \
+ scp2/source/ooo/installation_ooo \
+ scp2/source/ooo/module_help_template \
+ scp2/source/ooo/module_hidden_ooo \
+ scp2/source/ooo/module_lang_template \
+ scp2/source/ooo/profileitem_ooo \
+ scp2/source/ooo/scpaction_ooo \
+ $(if $(filter-out MACOSX WNT,$(OS)), \
+ scp2/source/ooo/module_libreofficekit \
+ ) \
+))
+
+$(eval $(call gb_InstallModule_add_localized_scpfiles,scp2/ooo,\
+ scp2/source/ooo/module_helppack \
+ scp2/source/ooo/module_langpack \
+ scp2/source/ooo/module_ooo \
+ scp2/source/ooo/module_systemint \
+))
+
+ifeq ($(ENABLE_PDFIMPORT),TRUE)
+$(eval $(call gb_InstallModule_add_scpfiles,scp2/ooo,\
+ scp2/source/ooo/module_pdfimport \
+))
+endif
+
+ifeq ($(ENABLE_REPORTBUILDER),TRUE)
+$(eval $(call gb_InstallModule_add_localized_scpfiles,scp2/ooo,\
+ scp2/source/ooo/module_reportbuilder \
+))
+endif
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: