summaryrefslogtreecommitdiffstats
path: root/scp2/InstallModule_python.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scp2/InstallModule_python.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scp2/InstallModule_python.mk')
-rw-r--r--scp2/InstallModule_python.mk49
1 files changed, 49 insertions, 0 deletions
diff --git a/scp2/InstallModule_python.mk b/scp2/InstallModule_python.mk
new file mode 100644
index 000000000..e4f3bd5f7
--- /dev/null
+++ b/scp2/InstallModule_python.mk
@@ -0,0 +1,49 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InstallModule_InstallModule,scp2/python))
+
+$(eval $(call gb_InstallModule_use_auto_install_libs,scp2/python,\
+ python \
+ python_scriptprovider \
+ $(call gb_Helper_optional,LIBRELOGO,python_librelogo) \
+))
+
+ifeq ($(DISABLE_PYTHON),TRUE)
+$(eval $(call gb_InstallModule_add_defs,scp2/python,\
+ -DDISABLE_PYUNO \
+))
+else ifneq ($(SYSTEM_PYTHON),)
+$(eval $(call gb_InstallModule_add_defs,scp2/python,\
+ -DSYSTEM_PYTHON \
+))
+
+else
+
+$(eval $(call gb_InstallModule_define_if_set,scp2/python,\
+ ENABLE_MACOSX_SANDBOX \
+))
+
+$(eval $(call gb_InstallModule_add_defs,scp2/python,\
+ -DPYVERSION=$(PYTHON_VERSION) \
+ $(call gb_Helper_optional,LIBRELOGO,-DENABLE_LIBRELOGO=1) \
+))
+endif
+
+$(eval $(call gb_InstallModule_add_scpfiles,scp2/python,\
+ scp2/source/python/file_python \
+ $(call gb_Helper_optional,LIBRELOGO,scp2/source/python/file_python_librelogo) \
+ scp2/source/python/module_python \
+))
+
+$(eval $(call gb_InstallModule_add_localized_scpfiles,scp2/python,\
+ $(call gb_Helper_optional,LIBRELOGO,scp2/source/python/module_python_librelogo) \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: