summaryrefslogtreecommitdiffstats
path: root/scp2/InstallScript_setup_osl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scp2/InstallScript_setup_osl.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scp2/InstallScript_setup_osl.mk')
-rw-r--r--scp2/InstallScript_setup_osl.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/scp2/InstallScript_setup_osl.mk b/scp2/InstallScript_setup_osl.mk
new file mode 100644
index 000000000..6f7b58204
--- /dev/null
+++ b/scp2/InstallScript_setup_osl.mk
@@ -0,0 +1,47 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InstallScript_InstallScript,setup_osl))
+
+$(eval $(call gb_InstallScript_use_modules,setup_osl,\
+ scp2/base \
+ scp2/calc \
+ scp2/draw \
+ scp2/graphicfilter \
+ scp2/impress \
+ scp2/math \
+ scp2/ooo \
+ scp2/python \
+ scp2/ure \
+ scp2/writer \
+ scp2/xsltfilter \
+ $(if $(filter WNT,$(OS)),\
+ scp2/activex \
+ scp2/quickstart \
+ scp2/spsupp \
+ scp2/windows \
+ $(if $(filter MSC,$(COM)),\
+ scp2/winexplorerext \
+ ) \
+ ) \
+ $(if $(WITH_EXTENSION_INTEGRATION),\
+ scp2/extensions \
+ ) \
+ $(if $(filter TRUE,$(ENABLE_EVOAB2) $(ENABLE_GIO) $(ENABLE_GTK3)),\
+ scp2/gnome \
+ ) \
+ $(if $(filter TRUE,$(ENABLE_QT5) $(ENABLE_KF5) $(ENABLE_GTK3_KDE5)),\
+ scp2/kde \
+ ) \
+ $(if $(filter TRUE,$(ENABLE_ONLINE_UPDATE)),\
+ scp2/onlineupdate \
+ ) \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: