summaryrefslogtreecommitdiffstats
path: root/scp2/Module_scp2.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scp2/Module_scp2.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scp2/Module_scp2.mk')
-rw-r--r--scp2/Module_scp2.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/scp2/Module_scp2.mk b/scp2/Module_scp2.mk
new file mode 100644
index 000000000..25ae8167d
--- /dev/null
+++ b/scp2/Module_scp2.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,scp2))
+
+$(eval $(call gb_Module_add_targets,scp2,\
+ AutoInstall \
+ CustomTarget_langmacros \
+ InstallModule_base \
+ InstallModule_calc \
+ InstallModule_draw \
+ InstallModule_extensions \
+ InstallModule_graphicfilter \
+ InstallModule_impress \
+ InstallModule_math \
+ InstallModule_onlineupdate \
+ InstallModule_ooo \
+ InstallModule_python \
+ InstallModule_spsupp \
+ InstallModule_ure \
+ InstallModule_writer \
+ InstallModule_xsltfilter \
+ InstallScript_setup_osl \
+ $(if $(filter ODK,$(BUILD_TYPE)), \
+ InstallModule_sdkoo \
+ InstallScript_sdkoo \
+ ) \
+ $(if $(filter WNT,$(OS)),\
+ InstallModule_activex \
+ InstallModule_quickstart \
+ InstallModule_windows \
+ InstallModule_winexplorerext \
+ ) \
+ $(if $(filter TRUE,$(ENABLE_EVOAB2) $(ENABLE_GIO) $(ENABLE_GTK3)),\
+ InstallModule_gnome \
+ ) \
+ $(if $(filter TRUE,$(ENABLE_QT5) $(ENABLE_KF5) $(ENABLE_GTK3_KDE5)),\
+ InstallModule_kde \
+ ) \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: