summaryrefslogtreecommitdiffstats
path: root/scripting/Jar_ScriptProviderForJavaScript.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scripting/Jar_ScriptProviderForJavaScript.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripting/Jar_ScriptProviderForJavaScript.mk')
-rw-r--r--scripting/Jar_ScriptProviderForJavaScript.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/scripting/Jar_ScriptProviderForJavaScript.mk b/scripting/Jar_ScriptProviderForJavaScript.mk
new file mode 100644
index 000000000..0366016bb
--- /dev/null
+++ b/scripting/Jar_ScriptProviderForJavaScript.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,ScriptProviderForJavaScript))
+
+$(eval $(call gb_Jar_use_jars,ScriptProviderForJavaScript,\
+ libreoffice \
+ ScriptFramework \
+))
+
+$(eval $(call gb_Jar_use_externals,ScriptProviderForJavaScript,\
+ rhino \
+))
+
+$(eval $(call gb_Jar_set_manifest,ScriptProviderForJavaScript,$(SRCDIR)/scripting/java/com/sun/star/script/framework/provider/javascript/MANIFEST.MF))
+
+$(eval $(call gb_Jar_set_componentfile,ScriptProviderForJavaScript,scripting/java/ScriptProviderForJavaScript,OOO,scriptproviderforjavascript))
+
+$(eval $(call gb_Jar_set_packageroot,ScriptProviderForJavaScript,com))
+
+$(eval $(call gb_Jar_add_sourcefiles,ScriptProviderForJavaScript,\
+ scripting/java/com/sun/star/script/framework/provider/javascript/ScriptEditorForJavaScript \
+ scripting/java/com/sun/star/script/framework/provider/javascript/ScriptProviderForJavaScript \
+))
+
+$(eval $(call gb_Jar_add_packagefile,ScriptProviderForJavaScript,\
+ com/sun/star/script/framework/provider/javascript/template.js,\
+ $(SRCDIR)/scripting/java/com/sun/star/script/framework/provider/javascript/template.js \
+))
+
+# vim: set noet sw=4 ts=4: