summaryrefslogtreecommitdiffstats
path: root/scripting/Library_protocolhandler.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scripting/Library_protocolhandler.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripting/Library_protocolhandler.mk')
-rw-r--r--scripting/Library_protocolhandler.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/scripting/Library_protocolhandler.mk b/scripting/Library_protocolhandler.mk
new file mode 100644
index 000000000..31599c3d8
--- /dev/null
+++ b/scripting/Library_protocolhandler.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,protocolhandler))
+
+$(eval $(call gb_Library_set_componentfile,protocolhandler,scripting/source/protocolhandler/protocolhandler,services))
+
+$(eval $(call gb_Library_set_include,protocolhandler,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/scripting/source/inc \
+))
+
+$(eval $(call gb_Library_use_external,protocolhandler,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,protocolhandler))
+
+$(eval $(call gb_Library_use_custom_headers,protocolhandler,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_use_libraries,protocolhandler,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ fwk \
+ sal \
+ sfx \
+ tl \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,protocolhandler,\
+ scripting/source/protocolhandler/scripthandler \
+))
+
+# vim: set noet sw=4 ts=4: