summaryrefslogtreecommitdiffstats
path: root/scripting/Module_scripting.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scripting/Module_scripting.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripting/Module_scripting.mk')
-rw-r--r--scripting/Module_scripting.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/scripting/Module_scripting.mk b/scripting/Module_scripting.mk
new file mode 100644
index 000000000..1d974e8e7
--- /dev/null
+++ b/scripting/Module_scripting.mk
@@ -0,0 +1,50 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,scripting))
+
+ifneq ($(filter SCRIPTING,$(BUILD_TYPE)),)
+
+$(eval $(call gb_Module_add_targets,scripting,\
+ $(if $(ENABLE_JAVA),\
+ Jar_HelloWorld \
+ Jar_Highlight \
+ Jar_MemoryUsage \
+ Jar_ScriptFramework \
+ $(if $(ENABLE_SCRIPTING_BEANSHELL),\
+ Jar_ScriptProviderForBeanShell \
+ Rdb_scriptproviderforbeanshell \
+ ) \
+ Jar_ScriptProviderForJava \
+ $(if $(ENABLE_SCRIPTING_JAVASCRIPT),\
+ Jar_ScriptProviderForJavaScript \
+ Rdb_scriptproviderforjavascript \
+ ) \
+ Package_java \
+ Package_java_jars \
+ $(if $(ENABLE_SCRIPTING_BEANSHELL),Package_ScriptsBeanShell) \
+ $(if $(ENABLE_SCRIPTING_JAVASCRIPT),Package_ScriptsJavaScript) \
+ ) \
+ Package_scriptbindinglib \
+ $(if $(DISABLE_PYTHON),,\
+ Package_scriptproviderforpython \
+ Package_ScriptsPython \
+ Pyuno_mailmerge \
+ ) \
+ Library_basprov \
+ Library_dlgprov \
+ Library_protocolhandler \
+ Library_scriptframe \
+ Library_stringresource \
+ Library_vbaevents \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: