summaryrefslogtreecommitdiffstats
path: root/scripting/Package_java.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /scripting/Package_java.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripting/Package_java.mk')
-rw-r--r--scripting/Package_java.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/scripting/Package_java.mk b/scripting/Package_java.mk
new file mode 100644
index 000000000..bbaa6e2b7
--- /dev/null
+++ b/scripting/Package_java.mk
@@ -0,0 +1,21 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Package_Package,scripting_java,$(SRCDIR)/scripting/examples/java))
+
+$(eval $(call gb_Package_add_files_with_dir,scripting_java,$(LIBO_SHARE_FOLDER)/Scripts/java,\
+ HelloWorld/HelloWorld.java \
+ HelloWorld/parcel-descriptor.xml \
+ Highlight/HighlightText.java \
+ Highlight/parcel-descriptor.xml \
+ MemoryUsage/MemoryUsage.java \
+ MemoryUsage/parcel-descriptor.xml \
+))
+
+# vim: set noet sw=4 ts=4: