summaryrefslogtreecommitdiffstats
path: root/sd/Module_sd.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sd/Module_sd.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sd/Module_sd.mk')
-rw-r--r--sd/Module_sd.mk77
1 files changed, 77 insertions, 0 deletions
diff --git a/sd/Module_sd.mk b/sd/Module_sd.mk
new file mode 100644
index 000000000..0ac7b5763
--- /dev/null
+++ b/sd/Module_sd.mk
@@ -0,0 +1,77 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/sd/export_setup.mk
+include $(SRCDIR)/sd/import_setup.mk
+
+$(eval $(call gb_Module_Module,sd))
+
+$(eval $(call gb_Module_add_targets,sd,\
+ Library_sd \
+ Library_sdd \
+ Library_sdfilt \
+ Library_sdui \
+ Package_opengl \
+ Package_web \
+ Package_xml \
+ UIConfig_sdraw \
+ UIConfig_simpress \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,sd,\
+ AllLangMoTarget_sd \
+))
+
+ifeq ($(filter DRAGONFLY FREEBSD,$(OS)),)
+$(eval $(call gb_Module_add_slowcheck_targets,sd,\
+ $(if $(and $(filter $(COM),MSC),$(MERGELIBS)),, \
+ CppunitTest_sd_uimpress) \
+ CppunitTest_sd_import_tests \
+ CppunitTest_sd_import_tests2 \
+ CppunitTest_sd_import_tests-smartart \
+ CppunitTest_sd_export_tests-ooxml1 \
+ CppunitTest_sd_export_tests-ooxml2 \
+ CppunitTest_sd_export_tests-ooxml3 \
+ CppunitTest_sd_export_tests \
+ CppunitTest_sd_filters_test \
+ CppunitTest_sd_layout_tests \
+ CppunitTest_sd_misc_tests \
+ CppunitTest_sd_uiimpress \
+ CppunitTest_sd_html_export_tests \
+ CppunitTest_sd_activex_controls_tests \
+ CppunitTest_sd_pdf_import_test \
+ CppunitTest_sd_png_export_tests \
+ CppunitTest_sd_filter_eppt \
+ CppunitTest_sd_shape_import_export_tests \
+))
+endif
+
+ifneq ($(DISABLE_GUI),TRUE)
+ifeq ($(OS),LINUX)
+$(eval $(call gb_Module_add_slowcheck_targets,sd,\
+ CppunitTest_sd_svg_export_tests \
+ CppunitTest_sd_tiledrendering \
+))
+endif
+endif
+
+# screenshots
+$(eval $(call gb_Module_add_screenshot_targets,sd, \
+ CppunitTest_sd_dialogs_test \
+))
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,sd,\
+ JunitTest_sd_unoapi \
+))
+
+$(eval $(call gb_Module_add_uicheck_targets,sd,\
+ UITest_impress_tests \
+ UITest_sd_findReplace \
+))
+# vim: set noet sw=4 ts=4: