summaryrefslogtreecommitdiffstats
path: root/sdext/CustomTarget_pdfimport.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sdext/CustomTarget_pdfimport.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sdext/CustomTarget_pdfimport.mk')
-rw-r--r--sdext/CustomTarget_pdfimport.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/sdext/CustomTarget_pdfimport.mk b/sdext/CustomTarget_pdfimport.mk
new file mode 100644
index 000000000..086daca5b
--- /dev/null
+++ b/sdext/CustomTarget_pdfimport.mk
@@ -0,0 +1,23 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,sdext/pdfimport))
+
+$(call gb_CustomTarget_get_target,sdext/pdfimport) : \
+ $(call gb_CustomTarget_get_workdir,sdext/pdfimport)/hash.cxx
+
+$(call gb_CustomTarget_get_workdir,sdext/pdfimport)/hash.cxx : \
+ $(SRCDIR)/sdext/source/pdfimport/wrapper/keyword_list \
+ | $(call gb_CustomTarget_get_workdir,sdext/pdfimport)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),GPF,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),GPF)
+ $(GPERF) -C -t -l -L C++ -m 20 --switch=2 --readonly-tables -Z PdfKeywordHash -k'4-5,$$' $< > $@
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),GPF)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: