summaryrefslogtreecommitdiffstats
path: root/setup_native/Library_sn_tools.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /setup_native/Library_sn_tools.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup_native/Library_sn_tools.mk')
-rw-r--r--setup_native/Library_sn_tools.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/setup_native/Library_sn_tools.mk b/setup_native/Library_sn_tools.mk
new file mode 100644
index 000000000..aa94f2ebc
--- /dev/null
+++ b/setup_native/Library_sn_tools.mk
@@ -0,0 +1,43 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,sn_tools))
+
+$(eval $(call gb_Library_add_defs,sn_tools,\
+ -U_DLL \
+))
+
+$(eval $(call gb_Library_add_cxxflags,sn_tools,\
+ $(if $(MSVC_USE_DEBUG_RUNTIME),/MTd,/MT) \
+))
+
+$(eval $(call gb_Library_add_ldflags,sn_tools,\
+ /DEF:$(SRCDIR)/setup_native/source/win32/customactions/tools/sn_tools.def \
+ /NODEFAULTLIB \
+))
+
+$(eval $(call gb_Library_add_exception_objects,sn_tools,\
+ setup_native/source/win32/customactions/tools/checkversion \
+))
+
+$(eval $(call gb_Library_use_static_libraries,sn_tools,\
+ seterror \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,sn_tools,\
+ libcmt \
+ libcpmt \
+ libucrt \
+ libvcruntime \
+ kernel32 \
+ msi \
+ advapi32 \
+))
+
+# vim: set noet sw=4 ts=4: