summaryrefslogtreecommitdiffstats
path: root/shell/CustomTarget_spsupp_idl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /shell/CustomTarget_spsupp_idl.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/CustomTarget_spsupp_idl.mk')
-rw-r--r--shell/CustomTarget_spsupp_idl.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/shell/CustomTarget_spsupp_idl.mk b/shell/CustomTarget_spsupp_idl.mk
new file mode 100644
index 000000000..2c860f6d8
--- /dev/null
+++ b/shell/CustomTarget_spsupp_idl.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,shell/source/win32/spsupp/idl))
+
+spsupp_IDLDIR := $(call gb_CustomTarget_get_workdir,shell/source/win32/spsupp/idl)
+
+$(call gb_CustomTarget_get_target,shell/source/win32/spsupp/idl) : \
+ $(spsupp_IDLDIR)/spsupp.tlb
+
+$(spsupp_IDLDIR)/spsupp.tlb : \
+ $(SRCDIR)/shell/source/win32/spsupp/spsupp.idl \
+ | $(spsupp_IDLDIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),IDL,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),IDL)
+ $(call gb_Helper_abbreviate_dirs, \
+ midl.exe \
+ -tlb $@ \
+ -h $(spsupp_IDLDIR)/spsupp_h.h \
+ -iid $(spsupp_IDLDIR)/spsupp_i.c \
+ $(INCLUDE) \
+ $(SOLARINC) \
+ -Oicf \
+ $<)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),IDL)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: