summaryrefslogtreecommitdiffstats
path: root/shell/Library_macbe.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /shell/Library_macbe.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/Library_macbe.mk')
-rw-r--r--shell/Library_macbe.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/shell/Library_macbe.mk b/shell/Library_macbe.mk
new file mode 100644
index 000000000..091b6d43a
--- /dev/null
+++ b/shell/Library_macbe.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,macbe1))
+
+$(eval $(call gb_Library_use_external,macbe1,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,macbe1))
+
+$(eval $(call gb_Library_use_system_darwin_frameworks,macbe1,\
+ Cocoa \
+ SystemConfiguration \
+))
+
+$(eval $(call gb_Library_use_libraries,macbe1,\
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_set_componentfile,macbe1,shell/source/backends/macbe/macbe1,services))
+
+$(eval $(call gb_Library_add_objcxxobjects,macbe1,\
+ shell/source/backends/macbe/macbackend \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: