summaryrefslogtreecommitdiffstats
path: root/shell/Library_propertyhdl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /shell/Library_propertyhdl.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/Library_propertyhdl.mk')
-rw-r--r--shell/Library_propertyhdl.mk57
1 files changed, 57 insertions, 0 deletions
diff --git a/shell/Library_propertyhdl.mk b/shell/Library_propertyhdl.mk
new file mode 100644
index 000000000..c0565b2d9
--- /dev/null
+++ b/shell/Library_propertyhdl.mk
@@ -0,0 +1,57 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,propertyhdl))
+
+$(eval $(call gb_Library_set_include,propertyhdl,\
+ -I$(SRCDIR)/shell/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_add_defs,propertyhdl,\
+ -DISOLATION_AWARE_ENABLED \
+ -DWIN32_LEAN_AND_MEAN \
+ -UNOMINMAX \
+))
+
+$(eval $(call gb_Library_use_externals,propertyhdl,\
+ expat \
+ zlib \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,propertyhdl,\
+ advapi32 \
+ comctl32 \
+ gdi32 \
+ gdiplus \
+ kernel32 \
+ msvcprt \
+ ole32 \
+ oleaut32 \
+ propsys \
+ shell32 \
+ shlwapi \
+ uuid \
+))
+
+$(eval $(call gb_Library_use_static_libraries,propertyhdl,\
+ shell_xmlparser \
+ shlxthandler_common \
+))
+
+$(eval $(call gb_Library_add_ldflags,propertyhdl,\
+ /DEF:$(SRCDIR)/shell/source/win32/shlxthandler/prophdl/propertyhdl.def \
+ /NODEFAULTLIB:libcmt.lib \
+))
+
+$(eval $(call gb_Library_add_exception_objects,propertyhdl,\
+ shell/source/win32/shlxthandler/prophdl/propertyhdl \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: