summaryrefslogtreecommitdiffstats
path: root/shell/StaticLibrary_xmlparser_x64.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /shell/StaticLibrary_xmlparser_x64.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/StaticLibrary_xmlparser_x64.mk')
-rw-r--r--shell/StaticLibrary_xmlparser_x64.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/shell/StaticLibrary_xmlparser_x64.mk b/shell/StaticLibrary_xmlparser_x64.mk
new file mode 100644
index 000000000..e52e5a373
--- /dev/null
+++ b/shell/StaticLibrary_xmlparser_x64.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,shell_xmlparser_x64))
+
+$(eval $(call gb_StaticLibrary_set_x64,shell_xmlparser_x64,YES))
+
+$(eval $(call gb_StaticLibrary_set_include,shell_xmlparser_x64,\
+ -I$(SRCDIR)/shell/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_StaticLibrary_use_externals,shell_xmlparser_x64,\
+ expat_x64 \
+))
+
+$(eval $(call gb_StaticLibrary_add_x64_generated_exception_objects,shell_xmlparser_x64,\
+ CustomTarget/shell/source/all/xml_parser \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: