summaryrefslogtreecommitdiffstats
path: root/slideshow/Library_OGLTrans.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /slideshow/Library_OGLTrans.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'slideshow/Library_OGLTrans.mk')
-rw-r--r--slideshow/Library_OGLTrans.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/slideshow/Library_OGLTrans.mk b/slideshow/Library_OGLTrans.mk
new file mode 100644
index 000000000..d059dc181
--- /dev/null
+++ b/slideshow/Library_OGLTrans.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,OGLTrans))
+
+ifneq ($(strip $(debug)$(DEBUG)),)
+$(eval $(call gb_Library_add_defs,OGLTrans,\
+ -DBOOST_SP_ENABLE_DEBUG_HOOKS \
+))
+endif
+
+$(eval $(call gb_Library_add_defs,OGLTrans,\
+ -DGLM_FORCE_RADIANS \
+))
+
+$(eval $(call gb_Library_use_sdk_api,OGLTrans))
+
+$(eval $(call gb_Library_use_libraries,OGLTrans,\
+ basegfx \
+ canvastools \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ vcl \
+))
+
+$(eval $(call gb_Library_use_externals,OGLTrans,\
+ boost_headers \
+ epoxy \
+ glm_headers \
+))
+
+$(eval $(call gb_Library_set_componentfile,OGLTrans,slideshow/source/engine/opengl/ogltrans,services))
+
+$(eval $(call gb_Library_add_exception_objects,OGLTrans,\
+ slideshow/source/engine/opengl/TransitionerImpl \
+ slideshow/source/engine/opengl/TransitionImpl \
+ slideshow/source/engine/opengl/Operation \
+))
+
+# vim: set noet sw=4 ts=4: