summaryrefslogtreecommitdiffstats
path: root/solenv/gbuild/InternalUnoApi.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /solenv/gbuild/InternalUnoApi.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'solenv/gbuild/InternalUnoApi.mk')
-rw-r--r--solenv/gbuild/InternalUnoApi.mk82
1 files changed, 82 insertions, 0 deletions
diff --git a/solenv/gbuild/InternalUnoApi.mk b/solenv/gbuild/InternalUnoApi.mk
new file mode 100644
index 000000000..dae0cb503
--- /dev/null
+++ b/solenv/gbuild/InternalUnoApi.mk
@@ -0,0 +1,82 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(dir $(call gb_InternalUnoApi_get_target,%)).dir :
+ $(if $(wildcard $(dir $@)),,mkdir -p $(dir $(@)))
+
+$(dir $(call gb_InternalUnoApi_get_target,%))%/.dir :
+ $(if $(wildcard $(dir $@)),,mkdir -p $(dir $(@)))
+
+$(call gb_InternalUnoApi_get_target,%) :
+ $(call gb_Output_announce,$*,$(true),UNI,5) \
+ $(call gb_Trace_MakeMark,$*,UNI)
+ touch $@
+
+.PHONY : $(call gb_InternalUnoApi_get_clean_target,%)
+$(call gb_InternalUnoApi_get_clean_target,%) :
+ $(call gb_Output_announce,$*,$(false),UNI,5) \
+ $(call gb_Helper_abbreviate_dirs,\
+ rm -f $(call gb_InternalUnoApi_get_target,$*))
+
+define gb_InternalUnoApi_InternalUnoApi
+$(call gb_UnoApiTarget_UnoApiTarget,$(1),$(2))
+$(call gb_UnoApiHeadersTarget_UnoApiHeadersTarget,$(1))
+
+$(call gb_InternalUnoApi_get_target,$(1)) : $(call gb_UnoApiTarget_get_target,$(1))
+$(call gb_InternalUnoApi_get_target,$(1)) :| $(dir $(call gb_InternalUnoApi_get_target,$(1))).dir
+$(call gb_InternalUnoApi_get_clean_target,$(1)) : $(call gb_UnoApiHeadersTarget_get_clean_target,$(1))
+
+$$(eval $$(call gb_Module_register_target,$(call gb_InternalUnoApi_get_target,$(1)),$(call gb_InternalUnoApi_get_clean_target,$(1))))
+$(call gb_Helper_make_userfriendly_targets,$(1),InternalUnoApi)
+
+endef
+
+define gb_InternalUnoApi_add_idlfile
+$(call gb_UnoApiTarget_add_idlfile,$(1),$(2),$(3))
+
+endef
+
+define gb_InternalUnoApi_add_idlfiles
+$(call gb_UnoApiTarget_add_idlfiles,$(1),$(2),$(3))
+
+endef
+
+define gb_InternalUnoApi__use_api
+$(call gb_UnoApiTarget_use_api,$(1),$(2))
+$(call gb_UnoApiHeadersTarget_use_api,$(1),$(2))
+$(call gb_InternalUnoApi_get_target,$(1)) : $(call gb_UnoApiTarget_get_target,$(2))
+
+endef
+
+define gb_InternalUnoApi_use_api
+$(foreach rdb,$(2),$(call gb_InternalUnoApi__use_api,$(1),$(rdb)))
+
+endef
+
+# Express that the rdb $(2) depends on rdb $(3).
+#
+# This information is already available in the UnoApiTarget definition
+# for $(2), but this may not be loaded if we are building from a
+# different module. Thus, this is a necessary hack to make generation of
+# headers on demand work.
+#
+# I suppose it would be possible to store the list of required rdbs for
+# a rdb to a file and then load it when headers' generation is requested,
+# but it feels like overkill...
+define gb_InternalUnoApi_define_api_dependency
+$(call gb_UnoApiHeadersTarget_use_api,$(2),$(3))
+
+endef
+
+define gb_InternalUnoApi_define_api_dependencies
+$(foreach dep,$(3),$(call gb_InternalUnoApi_define_api_dependency,$(1),$(2),$(dep)))
+
+endef
+
+# vim: set noet sw=4 ts=4: