summaryrefslogtreecommitdiffstats
path: root/static/Module_static.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /static/Module_static.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'static/Module_static.mk')
-rw-r--r--static/Module_static.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/static/Module_static.mk b/static/Module_static.mk
new file mode 100644
index 000000000..a21b23557
--- /dev/null
+++ b/static/Module_static.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+$(eval $(call gb_Module_Module,static))
+
+ifeq ($(ENABLE_CUSTOMTARGET_COMPONENTS),TRUE)
+
+$(eval $(call gb_Module_add_targets,static,\
+ CustomTarget_components \
+ Library_components \
+))
+
+ifeq (EMSCRIPTEN,$(OS))
+$(eval $(call gb_Module_add_targets,static,\
+ CustomTarget_emscripten_fs_image \
+ CustomTarget_wasm-qt5-mandelbrot_moc \
+ Executable_wasm-qt5-mandelbrot \
+))
+endif
+
+endif
+
+# vim: set noet sw=4 ts=4: