summaryrefslogtreecommitdiffstats
path: root/store/Library_store.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /store/Library_store.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'store/Library_store.mk')
-rw-r--r--store/Library_store.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/store/Library_store.mk b/store/Library_store.mk
new file mode 100644
index 000000000..fe90755e6
--- /dev/null
+++ b/store/Library_store.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,store))
+
+$(eval $(call gb_Library_use_external,store,boost_headers))
+
+$(eval $(call gb_Library_add_defs,store,\
+ -DSTORE_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_libraries,store,\
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,store,\
+ store/source/object \
+ store/source/lockbyte \
+ store/source/storbase \
+ store/source/storbios \
+ store/source/storcach \
+ store/source/stordata \
+ store/source/stordir \
+ store/source/storlckb \
+ store/source/stortree \
+ store/source/storpage \
+ store/source/store \
+))
+
+# vim: set noet sw=4 ts=4: