summaryrefslogtreecommitdiffstats
path: root/svtools/CppunitTest_svtools_graphic.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /svtools/CppunitTest_svtools_graphic.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'svtools/CppunitTest_svtools_graphic.mk')
-rw-r--r--svtools/CppunitTest_svtools_graphic.mk57
1 files changed, 57 insertions, 0 deletions
diff --git a/svtools/CppunitTest_svtools_graphic.mk b/svtools/CppunitTest_svtools_graphic.mk
new file mode 100644
index 000000000..04e562e16
--- /dev/null
+++ b/svtools/CppunitTest_svtools_graphic.mk
@@ -0,0 +1,57 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,svtools_graphic))
+
+$(eval $(call gb_CppunitTest_use_externals,svtools_graphic,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_use_api,svtools_graphic,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,svtools_graphic))
+
+$(eval $(call gb_CppunitTest_use_vcl,svtools_graphic))
+
+$(eval $(call gb_CppunitTest_use_libraries,svtools_graphic, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ tl \
+ sal \
+ svt \
+ sw \
+ test \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_set_include,svtools_graphic,\
+ -I$(SRCDIR)/sw/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,svtools_graphic,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,svtools_graphic))
+
+$(eval $(call gb_CppunitTest_use_rdb,svtools_graphic,services))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svtools_graphic, \
+ svtools/qa/unit/GraphicObjectTest \
+))
+
+# vim: set noet sw=4 ts=4: