summaryrefslogtreecommitdiffstats
path: root/svtools/Executable_langsupport.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /svtools/Executable_langsupport.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'svtools/Executable_langsupport.mk')
-rw-r--r--svtools/Executable_langsupport.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/svtools/Executable_langsupport.mk b/svtools/Executable_langsupport.mk
new file mode 100644
index 000000000..176a88b15
--- /dev/null
+++ b/svtools/Executable_langsupport.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,langsupport))
+
+$(eval $(call gb_Executable_set_targettype_gui,langsupport,YES))
+
+$(eval $(call gb_Executable_set_include,langsupport,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/svtools/inc \
+ -I$(SRCDIR)/svtools/source/inc \
+))
+
+$(eval $(call gb_Executable_use_external,langsupport,boost_headers))
+
+$(eval $(call gb_Executable_use_sdk_api,langsupport))
+
+$(eval $(call gb_Executable_use_libraries,langsupport,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ svt \
+ tl \
+ ucbhelper \
+ vcl \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,langsupport,\
+ svtools/langsupport/langsupport \
+))
+
+# vim: set noet sw=4 ts=4: