summaryrefslogtreecommitdiffstats
path: root/svtools/Module_svtools.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /svtools/Module_svtools.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'svtools/Module_svtools.mk')
-rw-r--r--svtools/Module_svtools.mk61
1 files changed, 61 insertions, 0 deletions
diff --git a/svtools/Module_svtools.mk b/svtools/Module_svtools.mk
new file mode 100644
index 000000000..33af7b522
--- /dev/null
+++ b/svtools/Module_svtools.mk
@@ -0,0 +1,61 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Module_Module,svtools))
+
+$(eval $(call gb_Module_add_targets,svtools,\
+ Library_svt \
+ UIConfig_svt \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,svtools,\
+ AllLangMoTarget_svt \
+))
+
+$(eval $(call gb_Module_add_check_targets,svtools,\
+ CppunitTest_svtools_graphic \
+ CppunitTest_svtools_html \
+))
+
+ifeq ($(CROSS_COMPILING)$(DISABLE_DYNLOADING),)
+
+ifneq ($(OS),WNT)
+$(eval $(call gb_Module_add_targets,svtools,\
+ Executable_langsupport \
+))
+endif
+
+endif
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,svtools,\
+ JunitTest_svtools_unoapi \
+))
+
+# screenshots
+$(eval $(call gb_Module_add_screenshot_targets,svtools,\
+ CppunitTest_svtools_dialogs_test \
+))
+
+#todo: javapatches
+#todo: jpeg on mac in svtools/util/makefile.mk
+#todo: deliver errtxt.src as ehdl.srs
+#todo: nooptfiles filter, filterconfigitem, FilterConfigCache, SvFilterOptionsDialog
+#todo: map file
+
+# vim: set noet sw=4 ts=4: