summaryrefslogtreecommitdiffstats
path: root/svx/CppunitTest_svx_removewhichrange.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /svx/CppunitTest_svx_removewhichrange.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'svx/CppunitTest_svx_removewhichrange.mk')
-rw-r--r--svx/CppunitTest_svx_removewhichrange.mk62
1 files changed, 62 insertions, 0 deletions
diff --git a/svx/CppunitTest_svx_removewhichrange.mk b/svx/CppunitTest_svx_removewhichrange.mk
new file mode 100644
index 000000000..6819c4452
--- /dev/null
+++ b/svx/CppunitTest_svx_removewhichrange.mk
@@ -0,0 +1,62 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,svx_removewhichrange))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svx_removewhichrange, \
+ svx/qa/unit/removewhichrange \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,svx_removewhichrange, \
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,svx_removewhichrange, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ drawinglayer \
+ drawinglayercore \
+ editeng \
+ fwk \
+ i18nlangtag \
+ i18nutil \
+ sal \
+ salhelper \
+ sax \
+ sb \
+ sfx \
+ sot \
+ svl \
+ svt \
+ tk \
+ tl \
+ ucbhelper \
+ utl \
+ vcl \
+ xo \
+ $(call gb_Helper_optional,AVMEDIA,avmedia) \
+ $(call gb_Helper_optional,DBCONNECTIVITY,dbtools) \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,svx_removewhichrange, \
+ svxcore \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,svx_removewhichrange))
+
+ifeq ($(OS),MACOSX)
+$(eval $(call gb_CppunitTest_use_system_darwin_frameworks,svx_removewhichrange, \
+ Foundation \
+))
+endif
+
+# vim: set noet sw=4 ts=4: