summaryrefslogtreecommitdiffstats
path: root/sysui/Module_sysui.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sysui/Module_sysui.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sysui/Module_sysui.mk')
-rw-r--r--sysui/Module_sysui.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/sysui/Module_sysui.mk b/sysui/Module_sysui.mk
new file mode 100644
index 000000000..3f1ad7c65
--- /dev/null
+++ b/sysui/Module_sysui.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,sysui))
+
+ifneq ($(OS),WNT)
+ifneq ($(OS),MACOSX)
+$(eval $(call gb_Module_add_targets,sysui,\
+ CustomTarget_share \
+ Package_share \
+ $(if $(filter rpm,$(PKGFORMAT)),CustomTarget_rpm) \
+ $(if $(filter deb,$(PKGFORMAT)),CustomTarget_deb) \
+ $(if $(filter SOLARIS,$(OS)),CustomTarget_solaris) \
+))
+else # OS=MACOSX
+$(eval $(call gb_Module_add_targets,sysui,\
+ Package_osxicons \
+ CustomTarget_infoplist \
+ Package_infoplist \
+))
+endif
+endif
+
+# vim: set noet sw=4 ts=4: