summaryrefslogtreecommitdiffstats
path: root/testtools/CustomTarget_uno_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /testtools/CustomTarget_uno_test.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testtools/CustomTarget_uno_test.mk')
-rw-r--r--testtools/CustomTarget_uno_test.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/testtools/CustomTarget_uno_test.mk b/testtools/CustomTarget_uno_test.mk
new file mode 100644
index 000000000..4850e5ca6
--- /dev/null
+++ b/testtools/CustomTarget_uno_test.mk
@@ -0,0 +1,34 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,testtools/uno_test))
+
+# this target is phony to run it every time
+.PHONY : $(call gb_CustomTarget_get_target,testtools/uno_test)
+
+$(call gb_CustomTarget_get_target,testtools/uno_test) : \
+ $(call gb_Executable_get_runtime_dependencies,uno) \
+ $(call gb_InternalUnoApi_get_target,bridgetest) \
+ $(call gb_Package_get_target,instsetoo_native_setup_ure) \
+ $(call gb_Rdb_get_target,uno_services) \
+ $(call gb_Rdb_get_target,ure/services) \
+ $(call gb_UnoApi_get_target,udkapi)
+ifneq ($(gb_SUPPRESS_TESTS),)
+ @true
+else
+ $(call gb_Helper_abbreviate_dirs,\
+ $(call gb_Executable_get_command,uno) \
+ -s com.sun.star.test.bridge.BridgeTest \
+ -- com.sun.star.test.bridge.CppTestObject \
+ -env:LO_BUILD_LIB_DIR=$(call gb_Helper_make_url,$(gb_Library_WORKDIR_FOR_BUILD)) \
+ -env:URE_MORE_SERVICES=$(call gb_Helper_make_url,$(call gb_Rdb_get_target,uno_services)) \
+ -env:URE_MORE_TYPES=$(call gb_Helper_make_url,$(WORKDIR)/UnoApiTarget/bridgetest.rdb))
+endif
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: