summaryrefslogtreecommitdiffstats
path: root/testtools/Jar_testComponent.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /testtools/Jar_testComponent.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testtools/Jar_testComponent.mk')
-rw-r--r--testtools/Jar_testComponent.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/testtools/Jar_testComponent.mk b/testtools/Jar_testComponent.mk
new file mode 100644
index 000000000..c5d789d1c
--- /dev/null
+++ b/testtools/Jar_testComponent.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,testComponent))
+
+$(eval $(call gb_Jar_use_jars,testComponent,\
+ libreoffice \
+))
+
+$(eval $(call gb_Jar_use_api,testComponent,\
+ udkapi \
+))
+
+$(eval $(call gb_Jar_use_customtargets,testComponent,\
+ testtools/bridgetest_javamaker \
+))
+
+$(eval $(call gb_Jar_set_packageroot,testComponent,com))
+
+$(eval $(call gb_Jar_set_manifest,testComponent,$(SRCDIR)/testtools/com/sun/star/comp/bridge/manifest))
+
+$(eval $(call gb_Jar_set_componentfile,testComponent,testtools/source/bridgetest/testComponent,NONE,uno_services))
+
+$(eval $(call gb_Jar_add_packagedirs,testComponent,\
+ $(call gb_CustomTarget_get_workdir,testtools/bridgetest_javamaker)/test \
+))
+
+$(eval $(call gb_Jar_add_sourcefiles,testComponent,\
+ testtools/com/sun/star/comp/bridge/TestComponent \
+ testtools/com/sun/star/comp/bridge/CurrentContextChecker \
+ testtools/com/sun/star/comp/bridge/TestComponentMain \
+))