summaryrefslogtreecommitdiffstats
path: root/testtools/Library_bridgetest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /testtools/Library_bridgetest.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testtools/Library_bridgetest.mk')
-rw-r--r--testtools/Library_bridgetest.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/testtools/Library_bridgetest.mk b/testtools/Library_bridgetest.mk
new file mode 100644
index 000000000..a9fb4558f
--- /dev/null
+++ b/testtools/Library_bridgetest.mk
@@ -0,0 +1,35 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,testtools_bridgetest))
+
+$(eval $(call gb_Library_set_componentfile,testtools_bridgetest,testtools/source/bridgetest/bridgetest,uno_services))
+
+$(eval $(call gb_Library_use_internal_api,testtools_bridgetest,\
+ bridgetest \
+))
+
+$(eval $(call gb_Library_use_api,testtools_bridgetest,\
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_external,testtools_bridgetest,boost_headers))
+
+$(eval $(call gb_Library_use_libraries,testtools_bridgetest,\
+ cppu \
+ cppuhelper \
+ sal \
+ testtools_bridgetest-common \
+))
+
+$(eval $(call gb_Library_add_exception_objects,testtools_bridgetest,\
+ testtools/source/bridgetest/bridgetest \
+))
+
+# vim:set noet sw=4 ts=4: