summaryrefslogtreecommitdiffstats
path: root/testtools/qa/cli
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /testtools/qa/cli
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testtools/qa/cli')
-rw-r--r--testtools/qa/cli/CLITest.java100
-rw-r--r--testtools/qa/cli/makefile.mk73
-rw-r--r--testtools/qa/cli/readme.txt26
3 files changed, 199 insertions, 0 deletions
diff --git a/testtools/qa/cli/CLITest.java b/testtools/qa/cli/CLITest.java
new file mode 100644
index 000000000..c3d6f8919
--- /dev/null
+++ b/testtools/qa/cli/CLITest.java
@@ -0,0 +1,100 @@
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+package cli;
+
+
+import complexlib.ComplexTestCase;
+import java.io.*;
+
+public class CLITest extends ComplexTestCase
+{
+ @Override
+ public String[] getTestMethodNames()
+ {
+ // TODO think about trigger of sub-tests from outside
+ return new String[]
+ {
+ "runCLITests"
+ };
+ }
+
+ public void runCLITests()
+ {
+ try
+ {
+ String testProgram = System.getProperty("cli_test", "");
+ if (testProgram.length() == 0)
+ failed("Check the make file. Java must be called with -Dcli_test=pathtoexe");
+
+ String arg1 = System.getProperty("cli_test_arg", "");
+ if (arg1.length() == 0)
+ failed("Check the make file. Java must be called with " +
+ "-Dcli_test_arg=path_to_bootstrap_ini");
+ String[] cmdarray = new String[] {testProgram, arg1};
+
+ Process proc = null;
+ try{
+
+ proc = Runtime.getRuntime().exec(cmdarray);
+ new Reader(proc.getInputStream());
+ new Reader(proc.getErrorStream());
+
+
+ }
+ catch(Exception e)
+ {
+ System.out.println("\n ###" + e.getMessage() + "\n");
+
+ }
+ proc.waitFor();
+ int retVal = proc.exitValue();
+ if (retVal != 0)
+ failed("CLI test failed.");
+ } catch( java.lang.Exception e)
+ {
+ failed("Unexpected exception.");
+ }
+
+ }
+}
+
+
+/* This reads from an InputStream and discards the data.
+ */
+class Reader extends Thread
+{
+ private InputStream is;
+ public Reader(InputStream stream)
+ {
+ is = stream;
+ start();
+ }
+
+ @Override
+ public void run()
+ {
+ try
+ {
+ byte[] buf = new byte[1024];
+ while (-1 != is.read(buf)) {}
+ }
+ catch (java.io.IOException exc)
+ {
+ }
+ }
+}
diff --git a/testtools/qa/cli/makefile.mk b/testtools/qa/cli/makefile.mk
new file mode 100644
index 000000000..13ee0bb96
--- /dev/null
+++ b/testtools/qa/cli/makefile.mk
@@ -0,0 +1,73 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ := ..$/..
+PRJNAME := testtools
+TARGET := test_cli
+PACKAGE = cli
+
+.INCLUDE: settings.mk
+
+#----- compile .java files -----------------------------------------
+
+JARFILES = ridl.jar unoil.jar jurt.jar juh.jar java_uno.jar OOoRunner.jar
+JAVAFILES = CLITest.java
+JAVACLASSFILES = $(foreach,i,$(JAVAFILES) $(CLASSDIR)$/$(PACKAGE)$/$(i:b).class)
+
+#----- make a jar from compiled files ------------------------------
+
+MAXLINELENGTH = 100000
+
+JARCLASSDIRS = $(PACKAGE)
+JARTARGET = $(TARGET).jar
+JARCOMPRESS = TRUE
+
+ALLTAR:
+
+EXETARGET = $(BIN)$/cli_bridgetest_inprocess.exe
+EXEARG_WIN= $(BIN)$/cli_bridgetest_inprocess.ini
+
+EXEARG= $(strip $(subst,$/,/ $(EXEARG_WIN)))
+
+.IF "$(depend)" == ""
+ALL: ALLTAR
+.ELSE
+ALL: ALLDEP
+.ENDIF
+
+.INCLUDE: target.mk
+
+# --- Parameters for the test --------------------------------------
+
+# test base is java complex
+CT_TESTBASE = -TestBase java_complex
+
+# test looks something like the.full.package.TestName
+CT_TEST = -o $(PACKAGE:s\$/\.\).$(JAVAFILES:b)
+
+# start the runner application
+CT_APP = org.openoffice.Runner
+
+CT_NOOFFICE = -NoOffice
+# --- Targets ------------------------------------------------------
+
+RUN:
+.IF "$(OS)"=="WNT"
+ java -cp $(CLASSPATH) -Dcli_test=$(EXETARGET) -Dcli_test_arg=$(EXEARG) $(CT_APP) $(CT_NOOFFICE) $(CT_TESTBASE) $(CT_TEST)
+.ENDIF
+run: RUN
diff --git a/testtools/qa/cli/readme.txt b/testtools/qa/cli/readme.txt
new file mode 100644
index 000000000..34531936a
--- /dev/null
+++ b/testtools/qa/cli/readme.txt
@@ -0,0 +1,26 @@
+This test is for Windows only!
+
+The cli test uses .NET assemblies:
+cli_types.dll,
+cli_basetypes.dll,
+cli_ure.dll,
+cli_cppuhelper.dll.
+
+
+When an office is properly installed then these assemblies can be found in the
+global assembly cache (GAC), for example in c:\windows\assembly.
+
+When the test is run then the assemblies are used from the GAC. That is
+one has to make sure that one has the respective office installed.
+
+The test can also be run without an installed office. Then the assemblies are used
+which reside next to the executable. The testtools project copies the assemblies from
+the build environment into the wntmscixx\bin folder.
+
+However, if for some reason an assembly remains in the GAC than it is used no matter
+what.
+
+
+The qa test simply executes the cli_bridgetest_inprocess.exe. All console output is discarded.
+When the test fails one should directly run that executable. Then one may see the cause
+of the failure in the console.