summaryrefslogtreecommitdiffstats
path: root/ucb/CppunitTest_ucb_webdav_core.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /ucb/CppunitTest_ucb_webdav_core.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ucb/CppunitTest_ucb_webdav_core.mk')
-rw-r--r--ucb/CppunitTest_ucb_webdav_core.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/ucb/CppunitTest_ucb_webdav_core.mk b/ucb/CppunitTest_ucb_webdav_core.mk
new file mode 100644
index 000000000..0df1feeff
--- /dev/null
+++ b/ucb/CppunitTest_ucb_webdav_core.mk
@@ -0,0 +1,54 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,ucb_webdav_core))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,ucb_webdav_core))
+
+$(eval $(call gb_CppunitTest_use_libraries,ucb_webdav_core, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ svl \
+ test \
+ ucbhelper \
+ tl \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,ucb_webdav_core, \
+ ucpdav1 \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,ucb_webdav_core,\
+ boost_headers \
+ libxml2 \
+ curl \
+))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,ucb_webdav_core,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,ucb_webdav_core, \
+ ucb/qa/cppunit/webdav/webdav_resource_access \
+ ucb/qa/cppunit/webdav/webdav_propfindcache \
+ ucb/qa/cppunit/webdav/webdav_options \
+ ucb/qa/cppunit/webdav/webdav_local_neon \
+))
+
+$(eval $(call gb_CppunitTest_set_include,ucb_webdav_core,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/ucb/source/ucp/webdav-curl \
+))
+
+# vim: set noet sw=4 ts=4: