summaryrefslogtreecommitdiffstats
path: root/ucb/Library_srtrs1.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /ucb/Library_srtrs1.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ucb/Library_srtrs1.mk')
-rw-r--r--ucb/Library_srtrs1.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/ucb/Library_srtrs1.mk b/ucb/Library_srtrs1.mk
new file mode 100644
index 000000000..603b7e43b
--- /dev/null
+++ b/ucb/Library_srtrs1.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,srtrs1))
+
+$(eval $(call gb_Library_set_componentfile,srtrs1,ucb/source/sorter/srtrs1,services))
+
+$(eval $(call gb_Library_use_external,srtrs1,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,srtrs1))
+
+$(eval $(call gb_Library_use_libraries,srtrs1,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ ucbhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,srtrs1,\
+ ucb/source/sorter/sortdynres \
+ ucb/source/sorter/sortresult \
+))
+
+# vim: set noet sw=4 ts=4: