summaryrefslogtreecommitdiffstats
path: root/ucb/Library_ucpfile1.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /ucb/Library_ucpfile1.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ucb/Library_ucpfile1.mk')
-rw-r--r--ucb/Library_ucpfile1.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/ucb/Library_ucpfile1.mk b/ucb/Library_ucpfile1.mk
new file mode 100644
index 000000000..f67c69b78
--- /dev/null
+++ b/ucb/Library_ucpfile1.mk
@@ -0,0 +1,46 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,ucpfile1))
+
+$(eval $(call gb_Library_set_componentfile,ucpfile1,ucb/source/ucp/file/ucpfile1,services))
+
+$(eval $(call gb_Library_use_external,ucpfile1,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,ucpfile1))
+
+$(eval $(call gb_Library_use_libraries,ucpfile1,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ ucbhelper \
+ utl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,ucpfile1,\
+ ucb/source/ucp/file/bc \
+ ucb/source/ucp/file/filcmd \
+ ucb/source/ucp/file/filglob \
+ ucb/source/ucp/file/filid \
+ ucb/source/ucp/file/filinpstr \
+ ucb/source/ucp/file/filinsreq \
+ ucb/source/ucp/file/filnot \
+ ucb/source/ucp/file/filprp \
+ ucb/source/ucp/file/filrec \
+ ucb/source/ucp/file/filrow \
+ ucb/source/ucp/file/filrset \
+ ucb/source/ucp/file/filstr \
+ ucb/source/ucp/file/filtask \
+ ucb/source/ucp/file/prov \
+))
+
+# vim: set noet sw=4 ts=4: