summaryrefslogtreecommitdiffstats
path: root/ucb/Module_ucb.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /ucb/Module_ucb.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ucb/Module_ucb.mk')
-rw-r--r--ucb/Module_ucb.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/ucb/Module_ucb.mk b/ucb/Module_ucb.mk
new file mode 100644
index 000000000..7bbcc925e
--- /dev/null
+++ b/ucb/Module_ucb.mk
@@ -0,0 +1,47 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,ucb))
+
+$(eval $(call gb_Module_add_targets,ucb,\
+ Library_cached1 \
+ Library_srtrs1 \
+ Library_ucb1 \
+ $(if $(ENABLE_LIBCMIS),Library_ucpcmis1) \
+ $(if $(WITH_WEBDAV),Library_ucpdav1) \
+ Library_ucpexpand1 \
+ Library_ucpext \
+ Library_ucpfile1 \
+ $(if $(ENABLE_CURL),Library_ucpftp1) \
+ Library_ucphier1 \
+ Library_ucpimage \
+ Library_ucppkg1 \
+ Library_ucptdoc1 \
+))
+
+ifeq ($(ENABLE_GIO),TRUE)
+$(eval $(call gb_Module_add_targets,ucb,\
+ Library_ucpgio1 \
+))
+endif
+
+ifneq ($(WITH_WEBDAV),)
+
+$(eval $(call gb_Module_add_check_targets,ucb,\
+ CppunitTest_ucb_webdav_core \
+))
+
+endif
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,ucb,\
+ JunitTest_ucb_complex \
+ JunitTest_ucb_unoapi \
+))
+
+# vim: set noet sw=4 ts=4: