summaryrefslogtreecommitdiffstats
path: root/unoil
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /unoil
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoil')
-rw-r--r--unoil/BUCK21
-rw-r--r--unoil/CliUnoApi_oootypes.mk29
-rw-r--r--unoil/CustomTarget_javamaker.mk31
-rw-r--r--unoil/Jar_unoil.mk16
-rw-r--r--unoil/Makefile7
-rw-r--r--unoil/Module_unoil.mk27
-rw-r--r--unoil/README.md3
-rw-r--r--unoil/climaker/cli_oootypes_config28
-rw-r--r--unoil/climaker/incversions.txt22
-rw-r--r--unoil/climaker/version.txt23
-rw-r--r--unoil/pom.unoil.xml54
11 files changed, 261 insertions, 0 deletions
diff --git a/unoil/BUCK b/unoil/BUCK
new file mode 100644
index 000000000..e84663c81
--- /dev/null
+++ b/unoil/BUCK
@@ -0,0 +1,21 @@
+genrule(
+ name = 'unoil-src',
+ cmd = ' && '.join([
+ 'cd $TMP',
+ 'echo "FAKE SOURCE ARCHIVE" > README',
+ 'zip -qr $OUT *',
+ ]),
+ out = 'unoil-src.jar',
+ visibility = ['PUBLIC'],
+)
+
+genrule(
+ name = 'unoil-javadoc',
+ cmd = ' && '.join([
+ 'cd $TMP',
+ 'echo "FAKE JAVADOC ARCHIVE" > README',
+ 'zip -qr $OUT *',
+ ]),
+ out = 'unoil-javadoc.jar',
+ visibility = ['PUBLIC'],
+)
diff --git a/unoil/CliUnoApi_oootypes.mk b/unoil/CliUnoApi_oootypes.mk
new file mode 100644
index 000000000..69d0a128f
--- /dev/null
+++ b/unoil/CliUnoApi_oootypes.mk
@@ -0,0 +1,29 @@
+
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/unoil/climaker/version.txt
+
+$(eval $(call gb_CliUnoApi_CliUnoApi,cli_oootypes))
+
+$(eval $(call gb_CliUnoApi_set_assembly_version,cli_oootypes,$(CLI_OOOTYPES_NEW_VERSION)))
+
+$(eval $(call gb_CliUnoApi_set_configfile,cli_oootypes,unoil/climaker/cli_oootypes_config,unoil/climaker/version.txt))
+
+$(eval $(call gb_CliUnoApi_set_keyfile,cli_oootypes,$(SRCDIR)/cli_ure/source/cliuno.snk))
+
+$(eval $(call gb_CliUnoApi_set_policy,cli_oootypes,$(CLI_OOOTYPES_POLICY_ASSEMBLY),$(CLI_OOOTYPES_POLICY_VERSION)))
+
+$(eval $(call gb_CliUnoApi_wrap_api,cli_oootypes,offapi))
+
+$(eval $(call gb_CliUnoApi_use_api,cli_oootypes,udkapi))
+
+$(eval $(call gb_CliUnoApi_use_assembly,cli_oootypes,cli_uretypes))
+
+# vim: set noet sw=4 ts=4:
diff --git a/unoil/CustomTarget_javamaker.mk b/unoil/CustomTarget_javamaker.mk
new file mode 100644
index 000000000..97793d519
--- /dev/null
+++ b/unoil/CustomTarget_javamaker.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,unoil/javamaker))
+
+unoil_JAVADIR := $(call gb_CustomTarget_get_workdir,unoil/javamaker)
+
+$(call gb_CustomTarget_get_target,unoil/javamaker) : $(unoil_JAVADIR)/done
+
+$(unoil_JAVADIR)/done : \
+ $(call gb_UnoApi_get_target,offapi) \
+ $(call gb_UnoApi_get_target,udkapi) \
+ $(call gb_Executable_get_runtime_dependencies,javamaker) \
+ | $(unoil_JAVADIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),JVM,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),JVM)
+ $(call gb_Helper_abbreviate_dirs, \
+ rm -r $(unoil_JAVADIR) && \
+ $(call gb_Helper_execute,javamaker -O$(unoil_JAVADIR) \
+ $(call gb_UnoApi_get_target,offapi) \
+ -X$(call gb_UnoApi_get_target,udkapi)) && \
+ touch $@)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),JVM)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab:
diff --git a/unoil/Jar_unoil.mk b/unoil/Jar_unoil.mk
new file mode 100644
index 000000000..b0265c93f
--- /dev/null
+++ b/unoil/Jar_unoil.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,unoil))
+
+$(eval $(call gb_Jar_add_manifest_classpath,unoil, \
+ libreoffice.jar \
+))
+
+# vim:set noet sw=4 ts=4:
diff --git a/unoil/Makefile b/unoil/Makefile
new file mode 100644
index 000000000..ccb1c85a0
--- /dev/null
+++ b/unoil/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/unoil/Module_unoil.mk b/unoil/Module_unoil.mk
new file mode 100644
index 000000000..96c90e6b0
--- /dev/null
+++ b/unoil/Module_unoil.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,unoil))
+
+ifneq ($(ENABLE_JAVA),)
+$(eval $(call gb_Module_add_targets,unoil,\
+ CustomTarget_javamaker \
+ Jar_unoil \
+))
+endif
+
+ifeq ($(COM),MSC)
+ifneq ($(CPUNAME),AARCH64)
+$(eval $(call gb_Module_add_targets,unoil,\
+ CliUnoApi_oootypes \
+))
+endif
+endif
+
+# vim:set noet sw=4 ts=4:
diff --git a/unoil/README.md b/unoil/README.md
new file mode 100644
index 000000000..3ee4882d0
--- /dev/null
+++ b/unoil/README.md
@@ -0,0 +1,3 @@
+# Java UNO IDL Code Generator
+
+Maps IDL into java classes definitions. This is for `offapi`, while `ridljar` is for `udkapi`.
diff --git a/unoil/climaker/cli_oootypes_config b/unoil/climaker/cli_oootypes_config
new file mode 100644
index 000000000..9f436e84b
--- /dev/null
+++ b/unoil/climaker/cli_oootypes_config
@@ -0,0 +1,28 @@
+<?xml version="1.0"?>
+<!--
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+-->
+<configuration>
+ <runtime>
+ <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
+ <dependentAssembly>
+ <assemblyIdentity name="cli_oootypes" publicKeyToken="ce2cb7e279207b9e"/>
+ <bindingRedirect oldVersion="CLI_OOOTYPES_OLD_VERSION" newVersion="CLI_OOOTYPES_NEW_VERSION" />
+ </dependentAssembly>
+ </assemblyBinding>
+ </runtime>
+</configuration> \ No newline at end of file
diff --git a/unoil/climaker/incversions.txt b/unoil/climaker/incversions.txt
new file mode 100644
index 000000000..c5eaa3f90
--- /dev/null
+++ b/unoil/climaker/incversions.txt
@@ -0,0 +1,22 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+CLI_OOOTYPES_NEW_VERSION
+CLI_OOOTYPES_OLD_VERSION
+CLI_OOOTYPES_POLICY_VERSION
+
diff --git a/unoil/climaker/version.txt b/unoil/climaker/version.txt
new file mode 100644
index 000000000..ec48a082e
--- /dev/null
+++ b/unoil/climaker/version.txt
@@ -0,0 +1,23 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+CLI_OOOTYPES_NEW_VERSION=1.0.9.0
+CLI_OOOTYPES_OLD_VERSION=1.0.0.0-1.0.8.0
+CLI_OOOTYPES_POLICY_VERSION=9.0.0.0
+CLI_OOOTYPES_POLICY_ASSEMBLY=policy.1.0.cli_oootypes
+
diff --git a/unoil/pom.unoil.xml b/unoil/pom.unoil.xml
new file mode 100644
index 000000000..9991ed572
--- /dev/null
+++ b/unoil/pom.unoil.xml
@@ -0,0 +1,54 @@
+<project>
+ <modelVersion>4.0.0</modelVersion>
+ <groupId>org.libreoffice</groupId>
+ <artifactId>unoil</artifactId>
+ <version>@version@</version>
+ <packaging>jar</packaging>
+ <name>LibreOffice - Maps IDL into java classes definitions</name>
+ <description>Maps IDL into java classes definitions</description>
+ <url>https://www.libreoffice.org</url>
+
+ <dependencyManagement>
+ <dependencies>
+ <dependency>
+ <groupId>org.libreoffice</groupId>
+ <artifactId>libreoffice</artifactId>
+ <version>@version@</version>
+ </dependency>
+ </dependencies>
+ </dependencyManagement>
+
+ <licenses>
+ <license>
+ <name>Mozilla Public License, Version 2.0</name>
+ <url>https://www.mozilla.org/en-US/MPL/2.0</url>
+ <distribution>repo</distribution>
+ </license>
+ </licenses>
+
+ <scm>
+ <url>https://cgit.freedesktop.org/libreoffice/core</url>
+ <connection>https://gerrit.libreoffice.org/#/admin/projects/core</connection>
+ </scm>
+
+ <developers>
+ <developer>
+ <name>The Document Foundation</name>
+ </developer>
+ </developers>
+
+ <mailingLists>
+ <mailingList>
+ <name>LibreOffice Development Mailing List</name>
+ <post>libreoffice@lists.freedesktop.org</post>
+ <subscribe>http://lists.freedesktop.org/mailman/listinfo/libreoffice</subscribe>
+ <unsubscribe>http://lists.freedesktop.org/mailman/listinfo/libreoffice</unsubscribe>
+ <archive>http://lists.freedesktop.org/archives/libreoffice</archive>
+ </mailingList>
+ </mailingLists>
+
+ <issueManagement>
+ <url>https://bugs.documentfoundation.org</url>
+ <system>LibreOffice Issue Tracker</system>
+ </issueManagement>
+</project>