summaryrefslogtreecommitdiffstats
path: root/unoxml/Library_unoxml.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /unoxml/Library_unoxml.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoxml/Library_unoxml.mk')
-rw-r--r--unoxml/Library_unoxml.mk82
1 files changed, 82 insertions, 0 deletions
diff --git a/unoxml/Library_unoxml.mk b/unoxml/Library_unoxml.mk
new file mode 100644
index 000000000..a0a9d805a
--- /dev/null
+++ b/unoxml/Library_unoxml.mk
@@ -0,0 +1,82 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,unoxml))
+
+$(eval $(call gb_Library_set_componentfile,unoxml,unoxml/source/service/unoxml,services))
+
+$(eval $(call gb_Library_set_precompiled_header,unoxml,unoxml/inc/pch/precompiled_unoxml))
+
+$(eval $(call gb_Library_use_sdk_api,unoxml))
+
+$(eval $(call gb_Library_use_libraries,unoxml,\
+ ucbhelper \
+ sax \
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ tl \
+ xo \
+))
+
+$(eval $(call gb_Library_use_externals,unoxml,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_Library_add_exception_objects,unoxml,\
+ unoxml/source/dom/node \
+ unoxml/source/dom/document \
+ unoxml/source/dom/element \
+ unoxml/source/dom/attr \
+ unoxml/source/dom/cdatasection \
+ unoxml/source/dom/characterdata \
+ unoxml/source/dom/comment \
+ unoxml/source/dom/documentbuilder \
+ unoxml/source/dom/documentfragment \
+ unoxml/source/dom/documenttype \
+ unoxml/source/dom/entity \
+ unoxml/source/dom/entityreference \
+ unoxml/source/dom/notation \
+ unoxml/source/dom/processinginstruction \
+ unoxml/source/dom/text \
+ unoxml/source/dom/domimplementation \
+ unoxml/source/dom/elementlist \
+ unoxml/source/dom/childlist \
+ unoxml/source/dom/notationsmap \
+ unoxml/source/dom/entitiesmap \
+ unoxml/source/dom/attributesmap \
+ unoxml/source/dom/saxbuilder \
+ unoxml/source/xpath/xpathobject \
+ unoxml/source/xpath/nodelist \
+ unoxml/source/xpath/xpathapi \
+ unoxml/source/events/event \
+ unoxml/source/events/eventdispatcher \
+ unoxml/source/events/mutationevent \
+ unoxml/source/events/uievent \
+ unoxml/source/events/mouseevent \
+))
+
+$(eval $(call gb_Library_set_include,unoxml,\
+ -I$(SRCDIR)/unoxml/inc \
+ $$(INCLUDE) \
+))
+
+# vim: set noet sw=4 ts=4: