summaryrefslogtreecommitdiffstats
path: root/uui/CppunitTest_uui_dialogs_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /uui/CppunitTest_uui_dialogs_test.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'uui/CppunitTest_uui_dialogs_test.mk')
-rw-r--r--uui/CppunitTest_uui_dialogs_test.mk67
1 files changed, 67 insertions, 0 deletions
diff --git a/uui/CppunitTest_uui_dialogs_test.mk b/uui/CppunitTest_uui_dialogs_test.mk
new file mode 100644
index 000000000..90d17cfbc
--- /dev/null
+++ b/uui/CppunitTest_uui_dialogs_test.mk
@@ -0,0 +1,67 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitScreenShot,uui_dialogs_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,uui_dialogs_test, \
+ uui/qa/unit/uui-dialogs-test \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,uui_dialogs_test))
+
+$(eval $(call gb_CppunitTest_set_include,desktop_dialogs_test,\
+ -I$(SRCDIR)/uui/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,uui_dialogs_test, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ drawinglayer \
+ editeng \
+ i18nlangtag \
+ i18nutil \
+ msfilter \
+ oox \
+ sal \
+ salhelper \
+ sax \
+ sfx \
+ sot \
+ svl \
+ svt \
+ test \
+ tl \
+ ucbhelper \
+ unotest \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_CppunitTest_use_external,uui_dialogs_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,uui_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_ure,uui_dialogs_test))
+$(eval $(call gb_CppunitTest_use_vcl_non_headless_with_windows,uui_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_rdb,uui_dialogs_test,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,uui_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_uiconfigs,uui_dialogs_test,\
+ uui \
+))
+
+# vim: set noet sw=4 ts=4: