summaryrefslogtreecommitdiffstats
path: root/vcl/CppunitTest_vcl_dialogs_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /vcl/CppunitTest_vcl_dialogs_test.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vcl/CppunitTest_vcl_dialogs_test.mk')
-rw-r--r--vcl/CppunitTest_vcl_dialogs_test.mk68
1 files changed, 68 insertions, 0 deletions
diff --git a/vcl/CppunitTest_vcl_dialogs_test.mk b/vcl/CppunitTest_vcl_dialogs_test.mk
new file mode 100644
index 000000000..a602b4270
--- /dev/null
+++ b/vcl/CppunitTest_vcl_dialogs_test.mk
@@ -0,0 +1,68 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitScreenShot,vcl_dialogs_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,vcl_dialogs_test, \
+ vcl/qa/unit/vcl-dialogs-test \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,vcl_dialogs_test))
+
+$(eval $(call gb_CppunitTest_set_include,desktop_dialogs_test,\
+ -I$(SRCDIR)/vcl/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,vcl_dialogs_test, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ drawinglayer \
+ editeng \
+ i18nlangtag \
+ i18nutil \
+ msfilter \
+ oox \
+ sal \
+ salhelper \
+ sax \
+ sfx \
+ sot \
+ svl \
+ svt \
+ test \
+ tl \
+ tk \
+ ucbhelper \
+ unotest \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_CppunitTest_use_external,vcl_dialogs_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,vcl_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_ure,vcl_dialogs_test))
+$(eval $(call gb_CppunitTest_use_vcl_non_headless_with_windows,vcl_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_rdb,vcl_dialogs_test,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,vcl_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_uiconfigs,vcl_dialogs_test,\
+ vcl \
+))
+
+# vim: set noet sw=4 ts=4: