summaryrefslogtreecommitdiffstats
path: root/vcl/UIConfig_vcl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /vcl/UIConfig_vcl.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vcl/UIConfig_vcl.mk')
-rw-r--r--vcl/UIConfig_vcl.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/vcl/UIConfig_vcl.mk b/vcl/UIConfig_vcl.mk
new file mode 100644
index 000000000..703cef1e6
--- /dev/null
+++ b/vcl/UIConfig_vcl.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UIConfig_UIConfig,vcl))
+
+$(eval $(call gb_UIConfig_add_uifiles,vcl,\
+ vcl/uiconfig/ui/aboutbox \
+ vcl/uiconfig/ui/combobox \
+ vcl/uiconfig/ui/cupspassworddialog \
+ vcl/uiconfig/ui/dockingwindow \
+ vcl/uiconfig/ui/editmenu \
+ vcl/uiconfig/ui/errornocontentdialog \
+ vcl/uiconfig/ui/errornoprinterdialog \
+ vcl/uiconfig/ui/interimdockparent \
+ vcl/uiconfig/ui/interimtearableparent \
+ vcl/uiconfig/ui/menutogglebutton3 \
+ vcl/uiconfig/ui/menutogglebutton4 \
+ vcl/uiconfig/ui/printdialog \
+ vcl/uiconfig/ui/printerdevicepage \
+ vcl/uiconfig/ui/printerpaperpage \
+ vcl/uiconfig/ui/printerpropertiesdialog \
+ vcl/uiconfig/ui/printprogressdialog \
+ vcl/uiconfig/ui/querydialog \
+ vcl/uiconfig/ui/screenshotparent \
+ vcl/uiconfig/ui/wizard \
+))
+
+$(eval $(call gb_UIConfig_add_a11yerrors_uifiles,vcl,\
+ vcl/qa/cppunit/builder/demo \
+))
+
+# vim: set noet sw=4 ts=4: