summaryrefslogtreecommitdiffstats
path: root/winaccessibility/CustomTarget_ia2_idl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /winaccessibility/CustomTarget_ia2_idl.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'winaccessibility/CustomTarget_ia2_idl.mk')
-rw-r--r--winaccessibility/CustomTarget_ia2_idl.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/winaccessibility/CustomTarget_ia2_idl.mk b/winaccessibility/CustomTarget_ia2_idl.mk
new file mode 100644
index 000000000..40a985153
--- /dev/null
+++ b/winaccessibility/CustomTarget_ia2_idl.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,winaccessibility/ia2/idl))
+
+wina11y_COMIDLDIR := $(call gb_CustomTarget_get_workdir,winaccessibility/ia2/idl)
+wina11y_SOURCE := $(SRCDIR)/winaccessibility/source/UAccCOMIDL
+
+# We cannot depend on *.tlb because they only produced by IDL compiler
+# if idl contains 'library' statement.
+$(call gb_CustomTarget_get_target,winaccessibility/ia2/idl) : \
+ $(wina11y_COMIDLDIR)/AccessibleKeyBinding.h \
+ $(wina11y_COMIDLDIR)/AccessibleKeyStroke.h \
+ $(wina11y_COMIDLDIR)/Charset.h \
+ $(wina11y_COMIDLDIR)/UAccCOM.h \
+ $(wina11y_COMIDLDIR)/defines.h \
+ $(wina11y_COMIDLDIR)/ia2_api_all.h
+
+$(wina11y_COMIDLDIR)/%.h : $(wina11y_SOURCE)/%.idl \
+ | $(wina11y_COMIDLDIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),IDL,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),IDL)
+ $(call gb_Helper_abbreviate_dirs, \
+ midl.exe \
+ -tlb $(wina11y_COMIDLDIR)/$*.tlb \
+ -h $(wina11y_COMIDLDIR)/$*.h \
+ -iid $(wina11y_COMIDLDIR)/$*_i.c \
+ -dlldata $(wina11y_COMIDLDIR)/dlldata.c \
+ -proxy $(wina11y_COMIDLDIR)/$*_p.c \
+ -Oicf \
+ $(SOLARINC) \
+ -I $(wina11y_SOURCE) \
+ $<)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),IDL)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: