summaryrefslogtreecommitdiffstats
path: root/wizards/Module_wizards.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /wizards/Module_wizards.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'wizards/Module_wizards.mk')
-rw-r--r--wizards/Module_wizards.mk66
1 files changed, 66 insertions, 0 deletions
diff --git a/wizards/Module_wizards.mk b/wizards/Module_wizards.mk
new file mode 100644
index 000000000..580eafcde
--- /dev/null
+++ b/wizards/Module_wizards.mk
@@ -0,0 +1,66 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Module_Module,wizards))
+
+$(eval $(call gb_Module_add_targets,wizards,\
+ CustomTarget_share \
+ CustomTarget_wizards \
+ Package_access2base \
+ Package_depot \
+ Package_euro \
+ Package_form \
+ Package_gimmicks \
+ Package_import \
+ Package_share \
+ Package_scriptforge \
+ Package_sfdatabases \
+ Package_sfdialogs \
+ Package_sfdocuments \
+ Package_sfunittests \
+ Package_sfwidgets \
+ Package_standard \
+ Package_template \
+ Package_tools \
+ Package_tutorials \
+ Package_usr \
+ Package_wizards \
+ Package_wizards_properties \
+ Pyuno_fax \
+ Pyuno_letter \
+ Pyuno_agenda \
+ Pyuno_commonwizards \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,wizards,\
+ AllLangMoTarget_wiz \
+))
+
+ifeq ($(ENABLE_JAVA),TRUE)
+$(eval $(call gb_Module_add_targets,wizards,\
+ Jar_commonwizards \
+ Jar_form \
+ Jar_query \
+ Jar_report \
+ Jar_reportbuilder \
+ Jar_table \
+))
+endif
+
+# vim: set noet sw=4 ts=4: