summaryrefslogtreecommitdiffstats
path: root/wizards/Package_access2base.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /wizards/Package_access2base.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'wizards/Package_access2base.mk')
-rw-r--r--wizards/Package_access2base.mk63
1 files changed, 63 insertions, 0 deletions
diff --git a/wizards/Package_access2base.mk b/wizards/Package_access2base.mk
new file mode 100644
index 000000000..0689b748a
--- /dev/null
+++ b/wizards/Package_access2base.mk
@@ -0,0 +1,63 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Package_Package,wizards_basicsrvaccess2base,$(SRCDIR)/wizards/source/access2base))
+
+$(eval $(call gb_Package_add_files,wizards_basicsrvaccess2base,$(LIBO_SHARE_FOLDER)/basic/Access2Base,\
+ _License.xba \
+ acConstants.xba \
+ Application.xba \
+ Collect.xba \
+ CommandBar.xba \
+ CommandBarControl.xba \
+ Control.xba \
+ Database.xba \
+ DataDef.xba \
+ Dialog.xba \
+ dialog.xlb \
+ dlgFormat.xdl \
+ dlgTrace.xdl \
+ DoCmd.xba \
+ Event.xba \
+ Field.xba \
+ Form.xba \
+ L10N.xba \
+ Methods.xba \
+ Module.xba \
+ OptionGroup.xba \
+ PropertiesGet.xba \
+ PropertiesSet.xba \
+ Property.xba \
+ Python.xba \
+ Recordset.xba \
+ Root_.xba \
+ script.xlb \
+ SubForm.xba \
+ TempVar.xba \
+ Test.xba \
+ Trace.xba \
+ UtilProperty.xba \
+ Utils.xba \
+))
+
+$(eval $(call gb_Package_add_files,wizards_basicsrvaccess2base,$(LIBO_LIB_PYUNO_FOLDER),\
+ access2base.py \
+))
+
+# vim: set noet sw=4 ts=4: