summaryrefslogtreecommitdiffstats
path: root/writerfilter/CppunitTest_writerfilter_dmapper.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /writerfilter/CppunitTest_writerfilter_dmapper.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'writerfilter/CppunitTest_writerfilter_dmapper.mk')
-rw-r--r--writerfilter/CppunitTest_writerfilter_dmapper.mk57
1 files changed, 57 insertions, 0 deletions
diff --git a/writerfilter/CppunitTest_writerfilter_dmapper.mk b/writerfilter/CppunitTest_writerfilter_dmapper.mk
new file mode 100644
index 000000000..de1a8cea9
--- /dev/null
+++ b/writerfilter/CppunitTest_writerfilter_dmapper.mk
@@ -0,0 +1,57 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,writerfilter_dmapper))
+
+$(eval $(call gb_CppunitTest_use_externals,writerfilter_dmapper,\
+ boost_headers \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,writerfilter_dmapper, \
+ writerfilter/qa/cppunittests/dmapper/CellColorHandler \
+ writerfilter/qa/cppunittests/dmapper/DomainMapperTableHandler \
+ writerfilter/qa/cppunittests/dmapper/DomainMapper \
+ writerfilter/qa/cppunittests/dmapper/DomainMapper_Impl \
+ writerfilter/qa/cppunittests/dmapper/GraphicImport \
+ writerfilter/qa/cppunittests/dmapper/TextEffectsHandler \
+ writerfilter/qa/cppunittests/dmapper/PropertyMap \
+ writerfilter/qa/cppunittests/dmapper/SdtHelper \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,writerfilter_dmapper, \
+ basegfx \
+ comphelper \
+ cppu \
+ oox \
+ sal \
+ test \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,writerfilter_dmapper))
+
+$(eval $(call gb_CppunitTest_use_ure,writerfilter_dmapper))
+$(eval $(call gb_CppunitTest_use_vcl,writerfilter_dmapper))
+
+$(eval $(call gb_CppunitTest_use_rdb,writerfilter_dmapper,services))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,writerfilter_dmapper,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,writerfilter_dmapper))
+
+# we need to explicitly depend on library writerfilter because it is not implied
+# by a link relation
+$(call gb_CppunitTest_get_target,writerfilter_dmapper) : $(call gb_Library_get_target,writerfilter)
+
+# vim: set noet sw=4 ts=4: